Discourse shows server IP/localhost as user's IP

Hello, I’ve deployed Discourse on my own server, everything works normally except detecting user’s IP address, I’ve even made a php script (outside docker container) to get all headers where IP can be:

REMOTE_ADDR: 212.58.xxx.xxx
SERVER_ADDR: 85.25.xxx.xxx
HTTP_CF_CONNECTING_IP: 212.58.xxx.xxx
HTTP_CDN_LOOP: cloudflare
HTTP_X_REAL_IP: 162.158.xxx.xxx

Server has BrainyCP panel installed with Apache and Nginx (currently website uses Nginx, which reverse proxies the docker container)
HTTP_CF_CONNECTING_IP gives inside docker container, but outside they have normal values
Without changing the header using custom commands, Discourse displays server’s IP.

(Soon will add more details as my Discourse instance is now rebuilding)

I’m not really sure about your setup, but noticed cloudflare in your post. Did you add the CloudFlare template to your app.yml file?

  - "templates/cloudflare.template.yml"

EDIT: used the wrong " "

No, I’ve added it to the templates list, now waiting for rebuild

1 Like

Rebuilded, but it still shows server IP (I’ve commented custom commands

## Any custom commands to run after building
  - exec: echo "Beginning of custom commands"
  ## If you want to set the 'From' email address for your first registration, uncomment and change:
  ## After getting the first signup email, re-comment the line. It only needs to run once.
  - exec: rails r "SiteSetting.notification_email='noreply@zeronet.space'"
  #- replace:
  #   filename: /etc/nginx/conf.d/discourse.conf
  #   from: "types {"
  #   to: |
  #     set_real_ip_from;
  #     real_ip_header CF-Connection-IP;
  #     real_ip_recursive on;
  #     types {
  #- replace:
  #   filename: /etc/nginx/conf.d/discourse.conf
  #   from: $proxy_add_x_forwarded_for
  #   to: $send_http_cf_connection_ip;
  #   global: true
  - exec: echo "End of custom commands"

Do I need to uncomment them? (also want to notice that they not worked even before I’ve added cloudflare template to app.yml))

Uncommented, $sent_http_cf_connection_ip gives

Nginx is likely reporting not Discourse it self, you will probably need to set up realip in nginx

I’ve already added cloudflare.template.yml which adds realip directives, but still not working.
I’ve even removed custom commands which are changing to custom header and now Discourse reports server IP for all users instead of localhost.

Also this is the Nginx config for domain zeronet.space generated by the panel itself

server {
	listen 85.25.xxx.xx:443 ssl http2;
	server_name  zeronet.space www.zeronet.space;
	root  /home/ay0ks/workspace/sites/zeronet.space;
	# ssl on;
	ssl_certificate  /etc/certs/ay0ks/zeronet.space_1655753906.crt;
	ssl_certificate_key /etc/certs/ay0ks/zeronet.space_1655753906.key;
	#ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
	#ssl_ciphers  "HIGH:!RC4:!aNULL:!MD5:!kEDH";
	ssl_protocols TLSv1 TLSv1.1 TLSv1.2 TLSv1.3;
	ssl_prefer_server_ciphers on;
	add_header Strict-Transport-Security 'max-age=604800';
	access_log /etc/nginx/vhost_logs/zeronet.space_access;
	error_log /etc/nginx/vhost_logs/zeronet.space_error;
	location ~ /.well-known {
		allow all;
	location ~ /\.ht {
		deny all;
		access_log off;
		log_not_found off;

	location / {
		root /home/ay0ks/workspace/sites/zeronet.space;
		proxy_pass http://85.25.xxx.xx:31080; # Discourse is deployed on ports 31080/31443
		proxy_redirect     off;
		proxy_force_ranges on;
		proxy_set_header   Host $host;
		proxy_set_header   X-Real-IP $remote_addr;
		proxy_set_header   X-Forwarded-For $proxy_add_x_forwarded_for;
		proxy_set_header   X-Forwarded-Proto $scheme;
		proxy_set_header   HTTPS $scheme;
		proxy_cache off;
		proxy_cache_key "$request_method|$http_if_modified_since|$http_if_none_match|$host|$request_uri";
		#access_log /etc/nginx/vhost_logs//home/ay0ks/workspace/sites/zeronet.space;
		proxy_cache_valid 3s;
		proxy_cache_min_uses 2;
		# proxy_cache_lock on;
		# proxy_cache_use_stale error timeout;
		# proxy_cache_use_stale updating http_502 http_504;
		limit_conn lone 100;
		# limit_req zone=ltwo burst=10;
		client_body_buffer_size    128k;
		client_max_body_size       1024m;
		proxy_connect_timeout      180;
		proxy_send_timeout         180;
		proxy_read_timeout         180;
		send_timeout               180;
		proxy_buffer_size          4k;
		proxy_buffers              8 32k;
		proxy_busy_buffers_size    68k;
		proxy_temp_file_write_size 10m;

	# error_page  404              /404.html;
	# error_page   500 502 503 504  /50x.html;

Also I want to note the “path” of request:
User -> Cloudflare -> Server(Nginx -> Docker -> Discourse)
And note that user’s IP is visible outside docker in cloudflare’s header CF-Connecting-IP

I don’t know a lot about how the Cloudflare real IP stuff works but my suspicion is that your Discourse nginx will need set_real_ip_from to be the IP address that it sees your proxy nginx as. Some other internal address? The public address? Not sure which it would see.

Once you know what address that is, I think what I would do is leave the cloudflare template in there, then add a new replace just for set_real_ip_from.

In addition to that, your proxy nginx will need to be configured to pass along the CF-Connecting-IP header if it isn’t already configured to do so or doesn’t already do so by default. I can’t really help with this bit.

Same path as me, my issue was nginx wasn’t configured to take the docker IP as a range to set the realip on.

real_ip_header X-Forwarded-For;
real_ip_recursive on;

So i go User > Cloudflare > Server Nginx (SWAG Docker) > Discourse

proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Host $host;
proxy_set_header X-Forwarded-Proto https;
proxy_set_header X-Forwarded-Ssl on;
proxy_set_header X-Real-IP $remote_addr;
  - "templates/postgres.template.yml"
  - "templates/redis.template.yml"
  - "templates/web.template.yml"
  - "templates/web.ratelimited.template.yml"
## Uncomment these two lines if you wish to add Lets Encrypt (https)
#  - "templates/web.ssl.template.yml"
#  - "templates/web.letsencrypt.ssl.template.yml"
#  - "templates/web.socketed.template.yml"
  - "templates/cloudflare.template.yml"

This could be the cause of your problems. Try setting up discourse on a server without any panels or reverse proxies installed and report if you experience the same problem.

As a first step, start by ammending the location block for discourse to match up with the details provided here: Running other websites on the same machine as Discourse

1 Like

That’s not a solution of a problem, basically buying a new 30€/mo dedicated server can solve anything lol (this thread won’t exist then).

Will try and post results here

Do I need to add headers also in Discourse Nginx config? (inside docker) Because it’s still showing me server’s address instead of users

Based on your path that doesn’t make sense to me.

Your nginx goes to discourse to docker, why would your discourse be using it’s own nginx also?

Don’t know, I’ve added your Nginx directives to mine though the panel (also checked from ssh), but it still shows server’s ip

This is my app.yml:

## this is the all-in-one, standalone Discourse Docker container template
## After making changes to this file, you MUST rebuild
## /var/discourse/launcher rebuild app
## visit http://www.yamllint.com/ to validate this file as needed

  - "templates/postgres.template.yml"
  - "templates/redis.template.yml"
  - "templates/web.template.yml"
  - "templates/web.ratelimited.template.yml"
  - "templates/cloudflare.template.yml"
## Uncomment these two lines if you wish to add Lets Encrypt (https)
  #- "templates/web.ssl.template.yml"
  #- "templates/web.letsencrypt.ssl.template.yml"

## which TCP/IP ports should this container expose?
## If you want Discourse to share a port with another webserver like Apache or nginx,
## see https://meta.discourse.org/t/17247 for details
  - "31080:80"   # http
  - "31443:443" # https

  db_default_text_search_config: "pg_catalog.russian"

  ## Set db_shared_buffers to a max of 25% of the total memory.
  ## will be set automatically by bootstrap based on detected RAM, or you can override
  db_shared_buffers: "4096MB"

  ## can improve sorting performance, but adds memory usage per-connection
  #db_work_mem: "40MB"

  ## Which Git revision should this container use? (default: tests-passed)
  #version: tests-passed

  LC_ALL: ru_RU.UTF-8
  LANG: ru_RU.UTF-8

  ## How many concurrent web requests are supported? Depends on memory and CPU cores.
  ## will be set automatically by bootstrap based on detected CPUs, or you can override

  ## TODO: The domain name this Discourse instance will respond to
  ## Required. Discourse will not work with a bare IP number.
  DISCOURSE_HOSTNAME: 'zeronet.space'

  ## Uncomment if you want the container to be started with the same
  ## hostname (-h option) as specified above (default "$hostname-$config")

  ## TODO: List of comma delimited emails that will be made admin and developer
  ## on initial signup example 'user1@example.com,user2@example.com'
  DISCOURSE_DEVELOPER_EMAILS: 'contact@zeronet.space'

  ## TODO: The SMTP mail server used to validate new accounts and send notifications
  # SMTP ADDRESS, username, and password are required
  # WARNING the char '#' in SMTP password can cause problems!
  DISCOURSE_SMTP_ADDRESS: smtp.zeronet.space
  DISCOURSE_SMTP_USER_NAME: noreply@zeronet.space
  DISCOURSE_NOTIFICATION_EMAIL: "noreply@zeronet.space"
  #DISCOURSE_SMTP_DOMAIN: "zeronet.space"

  ## If you added the Lets Encrypt template, uncomment below to get a free SSL certificate

  ## The http or https CDN address for this Discourse instance (configured to pull)
  ## see https://meta.discourse.org/t/14857 for details
  #DISCOURSE_CDN_URL: https://discourse-cdn.example.com

  ## The maxmind geolocation IP address key for IP address lookup
  ## see https://meta.discourse.org/t/-/137387/23 for details

## The Docker container is stateless; all data is stored in /shared
  - volume:
      host: /var/discourse/shared/standalone
      guest: /shared
  - volume:
      host: /var/discourse/shared/standalone/log/var-log
      guest: /var/log

## Plugins go here
## see https://meta.discourse.org/t/19157 for details
    - exec:
        cd: $home/plugins
          - git clone https://github.com/discourse/docker_manager.git

## Any custom commands to run after building
  - exec: echo "Beginning of custom commands"
  ## If you want to set the 'From' email address for your first registration, uncomment and change:
  ## After getting the first signup email, re-comment the line. It only needs to run once.
  - exec: rails r "SiteSetting.notification_email='noreply@zeronet.space'"
  - exec: echo "End of custom commands"

The answer was linked above. You need something like this.


This fixed issues with ip detection (now everything works normal) but now some of images are not loading

EDIT: this was a cache issue, now everything works! Thank you all!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.