DNS Settings for Digital Ocean Droplet - Root Domain?

This isn’t a Discourse issue per se, but perhaps people who have set up digital ocean droplets can comment.

I’m trying to get the basic domain to resolve properly. The “www” domain is fine and has been operating for the past 4 months - but then I recently noticed that the bare “rapa…news” domain is not resolving.

Here is what my settings look like right now. What do I need to do to get the bare domain (sans www) to resolve properly?

The settings as they are configured fight now - are not working…

Any help greatly appreciated!

You need to setup an A record for rapamycin.news as well, pointing to the IP address

1 Like

Do I delete that Name record (rapamycin.news to www.rapamycin.news) that doesn’t seem to be doing anything?

Ah - I couldn’t add the new A record without first deleting that CNAME record. Thanks - I hope it works! Will update in a few hours.

the changes are live

Why don’t I get it when I try to access the site via my chrome browser - this is what I see:

clear your browser cache

If clearing your browser cache doesn’t work, it may be because you need a letsencrypt certificate to cover the non-www version.

There’s a bit of info on how to do that in this topic:

Or I think you can use something like this instead:

Clearing the browser worked! Thanks so much. Problem solved!

The easy solution is forcewww.com.

A harder solution is Setting up Let’s Encrypt with Multiple Domains.


Thanks Jay. Having them both pointing to the same IP address seems fine for now. I don’t anticipate the IP address changing very often, and can easily update both records when I need to.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.