Docker attach gives empty new line

Hello, I have an instance of docker (the supported image).

When I try to docker attach it just shows the cursor blinking on an empty line, there is no response to commands like ls.

1 Like

How about

docker exec -it app bash -c "your command here"
1 Like

Yes that worked (with ls)

1 Like

Great! Please mark as solved so the topic gets closed. Glad that worked!

1 Like


But I’d still like to know what the problem was


How can I functionally attach?

1 Like

Is it something like ./launcher enter app that you’re looking for? That’ll give you a shell prompt inside the container. I don’t know how to do it with docker directly, but maybe docker exec -it app bash

1 Like

Indeed that is my objective, I want to sniff around the database tables.

I will try docker exec -it app bash

I thought that this was what docker attach was for, but I’m not an expert.

Looking further based on the hints fomr @pfaffman and @Ed_S, this answer from SO explained it well (accepted answer)

EDIT: the point is that a web server is running on the image, so docker attach doesn’t work, but the exec command does

Then maybe use the data explorer plugin. That’s a much better way to explore the database.

But maybe you’d be interested in Administrative Bulk Operations

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.