Docker0 Missing (OpenVZ)

I am getting the docker0 not found error after completing discourse-setup and on future attempts to start and connect.
I am using Ubuntu 14.04.4 LTS (64 bit).
Just installed, well… if it’s technically installed at this point.
Tried starting docker manually, which works and returns a process ID, but then attempting to stop or check status on docker returns an error saying the service can’t be found, as though it’s not actually running.

All the topics on the matter seem really old and none of them helped, any more recent ideas on the matter?

PS, I put in the info for email related stuff when configuring and would love to not need to redo that process as I didn’t bother to write down the API key anywhere, so if I can fix the issue without reconfiguring that, that’d be nice, but I will if I have to.

Did you install via our official guide? Try the line that installs Docker again. Try apt-get uninstalling Docker as well.

I did, following the guide here: discourse/ at main · discourse/discourse · GitHub

Which doesn’t seem to be working.
Also, if it matters, I will be running it behind a host Nginx using this guide here:

However, can’t do that either as I can’t rebuild the app.

It has worked for me the last hundred times I have done it. Other than Nginx did you deviate from the install guide in any way, however small? Did you see an error in your scrollback when you ran the wget command to install Docker?

There was an error towards the end, but I assumed it was a small thing that didn’t matter much as it gave another message shortly after that it had finished (and I assumed it finished sufficiently to work). Unfortunately, that was a few SSH sessions ago, what should I do to remove everything so I can rerun that process and get you the exact error message?

No changes aside from the config files as directed in the Nginx guide. After I did it I realized that the exact instructions may not work with my Nginx setup, but I figured that’s not what’s preventing it from starting up properly (as appears to be the current issue). So I may end up changing the Nginx settings some later on.

Use the apt-get commands to remove Docker. Then reinstall it.

Alright, I did apt-get purge docker (I didn’t think to do docker-engine as well until after I saw the installer script stated that it was already installed), here’s the output from the wget command.

Warning: the "docker" command appears to already exist on this system.

If you already have Docker installed, this script can cause trouble, which is
why we're displaying this warning and provide the opportunity to cancel the

If you installed the current Docker package using this script and are using it
again to update Docker, you can safely ignore this message.

You may press Ctrl+C now to abort this script.
+ sleep 20
modprobe: ERROR: ../libkmod/libkmod.c:507 kmod_lookup_alias_from_builtin_file() could not open builtin file '/lib/modules/2.6.32-042stab093.4/modules.builtin.bin'
modprobe: FATAL: Module aufs not found.
Warning: current kernel is not supported by the linux-image-extra-virtual
 package.  We have no AUFS support.  Consider installing the packages
 linux-image-virtual kernel and linux-image-extra-virtual for AUFS support.
+ sleep 10
+ sh -c apt-key adv --keyserver hkp:// --recv-keys 58118E89F3A912897C070ADBF76221572C52609D
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.Q0VguggssP --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp:// --recv-keys 58118E89F3A912897C070ADBF76221572C52609D
gpg: requesting key 2C52609D from hkp server
gpg: key 2C52609D: "Docker Release Tool (releasedocker) <>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
+ break
+ sh -c apt-key adv -k 58118E89F3A912897C070ADBF76221572C52609D >/dev/null
+ sh -c mkdir -p /etc/apt/sources.list.d
+ dpkg --print-architecture
+ sh -c echo deb [arch=amd64] ubuntu-trusty main > /etc/apt/sources.list.d/docker.list
+ sh -c sleep 3; apt-get update; apt-get install -y -q docker-engine
Get:1 trusty-security InRelease [65.9 kB]
Ign trusty InRelease
Ign trusty InRelease
Get:2 trusty Release.gpg [933 B]
Get:3 trusty-updates InRelease [65.9 kB]
Get:4 trusty Release [9359 B]
Get:5 trusty-security/main amd64 Packages [485 kB]
Get:6 trusty/partner amd64 Packages [5622 B]
Hit trusty Release.gpg
Get:7 trusty/partner i386 Packages [6289 B]
Get:8 trusty-updates/main amd64 Packages [773 kB]
Get:9 trusty/partner Translation-en [4593 B]
Get:10 ubuntu-trusty InRelease
Ign ubuntu-trusty InRelease
Hit ubuntu-trusty Release.gpg
Get:11 trusty-security/restricted amd64 Packages [13.0 kB]
Hit ubuntu-trusty Release
Get:12 trusty-security/universe amd64 Packages [130 kB]
Hit ubuntu-trusty/main amd64 Packages
Get:13 trusty-updates/restricted amd64 Packages [15.9 kB]
Get:14 ubuntu-trusty/main Translation-en
Get:15 trusty-security/multiverse amd64 Packages [4978 B]
Get:16 trusty-updates/universe amd64 Packages [361 kB]
Get:17 trusty-security/main i386 Packages [458 kB]
Get:18 trusty-updates/main i386 Packages [740 kB]
Get:19 trusty-security/restricted i386 Packages [12.7 kB]
Ign ubuntu-trusty/main Translation-en
Get:20 trusty-security/universe i386 Packages [130 kB]
Get:21 trusty-security/multiverse i386 Packages [5168 B]
Hit trusty-security/main Translation-en
Get:22 trusty-updates/restricted i386 Packages [15.6 kB]
Hit trusty-security/multiverse Translation-en
Get:23 trusty-updates/universe i386 Packages [363 kB]
Hit trusty-security/restricted Translation-en
Hit trusty-security/universe Translation-en
Get:24 trusty-updates/main Translation-en [387 kB]
Get:25 trusty-updates/restricted Translation-en [3699 B]
Get:26 trusty-updates/universe Translation-en [189 kB]
Hit trusty Release
Hit trusty/main amd64 Packages
Hit trusty/restricted amd64 Packages
Hit trusty/universe amd64 Packages
Hit trusty/main i386 Packages
Hit trusty/restricted i386 Packages
Hit trusty/universe i386 Packages
Hit trusty/main Translation-en
Hit trusty/restricted Translation-en
Hit trusty/universe Translation-en
Fetched 4245 kB in 4s (942 kB/s)
Reading package lists... Done
Reading package lists...
Building dependency tree...
Reading state information...
docker-engine is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
+ sh -c docker version
 Version:      1.11.2
 API version:  1.23
 Go version:   go1.5.4
 Git commit:   b9f10c9
 Built:        Wed Jun  1 21:47:50 2016
 OS/Arch:      linux/amd64
Cannot connect to the Docker daemon. Is the docker daemon running on this host?

If you would like to use Docker as a non-root user, you should now consider
adding your user to the "docker" group with something like:

  sudo usermod -aG docker your-user

Remember that you will have to log out and back in for this to take effect!

looks good to me, check it with docker version and docker info as well.

So does the AUFS error not matter to anything then?

root@r-ri:/var/discourse# docker version
 Version:      1.11.2
 API version:  1.23
 Go version:   go1.5.4
 Git commit:   b9f10c9
 Built:        Wed Jun  1 21:47:50 2016
 OS/Arch:      linux/amd64
Cannot connect to the Docker daemon. Is the docker daemon running on this host?
root@r-ri:/var/discourse# docker info
Cannot connect to the Docker daemon. Is the docker daemon running on this host?

Nope you are still boned. Sorry.

I’ve installed literally hundreds of times on Digital Ocean with Ubuntu 14.04 using our standard install doc. Did you deviate from the install doc in any way?

I would just destroy the droplet and start over, and follow the install doc to the letter.

Turns out the problem was that I was running on a VM inside an OpenVZ container, I was unaware that OpenVZ couldn’t run Docker (I don’t fully understand why, but whatever…). I am now running on a KVM server and the installation completed successfully. Now to get my vBulletin site migrated…


I ran into the same problem on my proxmox server. Wasted a couple hours before I figured it out. Hopefully others find this and save themselves a bit of time.

I guess recent OpenVZ can?

no clue if that’ll result in a supported Discourse