"download my posts" issue


(Eli the Bearded) #1

Noticed elsewhere and duplicated here:

In the last month or two the URL format for posts (“url” column in the CSV) has changed. It used to always be https:// now it is http://.

Probably related to the change where email goes out with all the URLs as http:// instead of https://

That would put the date on or after June 30th and on or before July 6th.

(This is happening to email from Let’s Encrypt:

 A brief summary of <a href="http://community.letsencrypt.org"
 style="text-decoration: none; font-weight: bold; color: #006699;; color: #0088cc"
 >Let's Encrypt Community Support</a> since your last visit on

Tsk, tsk.)


(Jeff Atwood) #2

Sure @techapj we should fix this before 1.6 release.


(Arpit Jalan) #3

I believe this issue is specific to Discourse hosted instances.

Currently debugging, will post here when I have more info to share.


(Eli the Bearded) #4

A bit of an aside here, but is there an easy way (as a user) to distinguish between Discourse hosted and otherwise hosted?


(Kane York) #5

If you “view source” on the page and the scripts are coming from cdn-something.discourse.org, that’s pretty much all you need to check.


(Eli the Bearded) #6

Did you fix something? My most recent Let’s Encrypt digest arrived with https URLs back, and testing here the https urls in the post download CSV are back.


(Alan Tan) #7

Yup we were unintentionally overriding the force_https site setting for our hosted customers and have reverted it.


(Arpit Jalan) #8