Emoji within quotation marks not displaying correctly in topic excerpt

For pinned posts where a topic excerpt is displayed — on the /latest page or the relevant category page — the emoji is displayed as, for example:

  • ":smile:" rather than “:smile:
  • ':smile:' rather than ‘:smile:
  • ":smile: some text" rather than “:smile: some text”.

The following are fine:

  • “some text :smile: some text”
  • “some text :smile:

This isn’t a huge problem but I wonder whether it’s something that could be changed or worked around.

The correct syntax for emojis to work properly is that there is at least one blank space before the emoji, so all emojis will be shown correctly on the excerpt as well using the correct syntax:

  • " :smile: "
  • ' :smile: '
  • " :smile:
  • ' :smile:

This is not a bug, moving to #ux.


That’s great, thanks. Where is this sort of thing documented?



Is there a user’s guide about Discourse’s markup (eg including how to put emojis in quotation marks)?

I’ve tried this — the quotation marks don’t convert turn into “smart quotes” and the space between the " and the emoji is displayed. Is there a good way of not displaying the space character? Thank you.

See the site setting markdown typographer quotation marks

I don’t think there is a way to hide the space :thinking:


Thanks for this. Normally the curly quotation marks do appear. I’ll just cut and paste them in this case.