ENOENT no such file or directory error during upgrade

The upgrade process failed and my forum is down unfortunately. Just beginning to dive into the issue, but here’s the error it choked on:

Error: ENOENT: no such file or directory, open 'root='/assets',url='/assets/vendor-4681e47c140b5a5bea2bfb1fec89365858288a8ea0c21979c0167ad9b570ee3d.js.map''
    at Object.openSync (fs.js:443:3)
    at Object.writeFileSync (fs.js:1194:35)
    at done (/usr/lib/node_modules/uglify-js/bin/uglifyjs:516:20)
    at cb (/usr/lib/node_modules/uglify-js/bin/uglifyjs:324:39)
    at /usr/lib/node_modules/uglify-js/bin/uglifyjs:391:9
    at FSReqWrap.readFileAfterClose [as oncomplete] (internal/fs/read_file_context.js:53:3)
rake aborted!

Help would be appreciated if you recognize specifically what’s going on.

1 Like

You might try

cd /var/discourse
git pull
./launcher rebuild app

./launcher rebuild says “Rebuild a container (destroy old, bootstrap, start new)”. Is the forum’s data stored outside of the container? Or will I need to come up from a backup after I run that?

1 Like

Given that you did a standard install, it is in /var/discourse/shared/standalone/postgres_data. So you’re safe to rebuild.


Thanks, rebuilding worked. I’ll remember how to do that, very useful.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.