ERR_INVALID_RESPONSE trying to get push_service_worker.js


#1

I’m running Discourse in a docker container behind a reverse proxy with Apache, so my app.yml config file is
expose:
- “8080:80” # http
- “4443:443” # https
The reverse proxy works for http connections. I installed a ssl certificate with letsencrypt as explained here, and it works too.
Chrome Developer Tools show that if fails to GET push-service-worker.js


Browsing https://foro.soybiotec.es/push-service-worker.js in Chrome gives Discourse custom error 404 page. What could be the problem here?


(Rafael dos Santos Silva) #2

Why are you exposing 4443 if https is done on Apache?


#3

@Falco At first I thought the way to have a https would be to have another reverse proxy, same as for http.


(Rafael dos Santos Silva) #4

Did you enable the plugin on settings? Also is force_ssl enabled?


#5

I had just uninstalled the plugin for testing. Installed and activated and error disappears. Sorry for being so dummy. I thought I had found the reason why Push Notifications don’t work for me.