Error at LetsEncrypt validation

I have setup the self-hosted Docker environment and enabled HTTPS using Let’s Encrypt following the tutorial.

It always fails on the step below. Setup without HTTPS works fine and the forum is publicly available on HTTP.

root@discoursetest3-app:/shared/letsencrypt# cat

[Mon 11 Apr 2022 02:56:35 PM UTC] error:Fetching Timeout after connect (your server may be slow or overloaded)

It seems that ACME challenge is not accessible.

Did you read the first sentence in that guide that says that if you’re doing a standard install you don’t need to follow that guide?

Is this a recent standard install? Did you run discourse-setup?

It looks like you may have port 80 (and perhaps also port 443) blocked for incoming connections.

1 Like

Oddly, the first works but the second doesn’t:

○ → curl

○ → timeout -v 5s curl
timeout: sending signal TERM to command ‘curl’

I’m not sure what would cause that if it’s a standard setup.

1 Like

It is an old test installation without HTTPS and now I would like to enable HTTPS.
I have tried to edit app.yml manually and also to run discourse-setup. In both cases the same error.
I have also tried to delete Discourse (containers and files) and install from scratch, but the result is the same.

I agree that it looks that port 80 in not available, but if I comment the following two lines in app.yml, the forum runs on HTTP without problem.

  • “templates/web.ssl.template.yml”
  • “templates/web.letsencrypt.ssl.template.yml”

Where on the disk are static files like

It has turned out that just ACME protocol was blocked on the company firewall. Now it works :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.