Error connecting to Redis on localhost:6379

So unlike all the other topics regarding this same exact error I’m not sure I’m getting this error for the same reason as many other posters. I get to the point where I can make an admin account but nothing happens after hitting ‘Register’.

More background information. I’m trying to install discourse on a locally hosted Ubuntu server. I’ve been following discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub to the T and have scoured multiple topics to see if anyone else had taken the same steps before me no avail.

Anyway. This is what I end up with upon viewing the production.log (I’ve shortened it a bit for readability)

> Error connecting to Redis on localhost:6379 (Errno::ECONNREFUSED) subscribe failed, reconnecting in 1 second. Call stack ["/var/www/discourse/vendor/bundle/ruby
> /2.6.0/gems/redis-4.0.1/lib/redis/client.rb:344:in `rescue in establish_connecti
> on'", "/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/redis-4.0.1/lib/redis/cl
> ient.rb:328:in `establish_connection'" 
> 
> [...]
> 
> Job exception: Error connecting to Redis on localhost:6379 (Errno::ECONNREFUSED)

Reading back through the terminal after installation I noted some things that could be causing the issue? However this is my first time installing discourse and also my first time using docker so I’m rather clueless as to what it all means, if it means anything at all.

> 184:C 10 Jun 2019 03:15:01.639 # Configuration loaded
>                 _._                                                  
>            _.-``__ ''-._                                             
>       _.-``    `.  `_.  ''-._           Redis 5.0.4 (00000000/0) 64 bit
>   .-`` .-```.  ```\/    _.,_ ''-._                                   
>  (    '      ,       .-`  | `,    )     Running in standalone mode
>  |`-._`-...-` __...-.``-._|'` _.-'|     Port: 6379
>  |    `-._   `._    /     _.-'    |     PID: 184
>   `-._    `-._  `-./  _.-'    _.-'                                   
>  |`-._`-._    `-.__.-'    _.-'_.-'|                                  
>  |    `-._`-._        _.-'_.-'    |           http://redis.io        
>   `-._    `-._`-.__.-'_.-'    _.-'                                   
>  |`-._`-._    `-.__.-'    _.-'_.-'|                                  
>  |    `-._`-._        _.-'_.-'    |                                  
>   `-._    `-._`-.__.-'_.-'    _.-'                                   
>       `-._    `-.__.-'    _.-'                                       
>           `-._        _.-'                                           
>               `-.__.-'                                               
> 
> 184:M 10 Jun 2019 03:15:01.640 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
> 184:M 10 Jun 2019 03:15:01.640 # Server initialized
> 184:M 10 Jun 2019 03:15:01.640 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
> 184:M 10 Jun 2019 03:15:01.640 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
> 184:M 10 Jun 2019 03:15:01.643 * DB loaded from disk: 0.003 seconds
> 184:M 10 Jun 2019 03:15:01.643 * Ready to accept connections
> 
> [...]
> 
> INFO -- : Replacing # postgres with sv start postgres || exit 1 in /etc/service/unicorn/run
> I, [2019-06-10T03:15:11.961165 #14]  INFO -- : > exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf
> I, [2019-06-10T03:15:11.965685 #14]  INFO -- : > cd /var/www/discourse && git reset --hard
> 211:C 10 Jun 2019 03:15:11.972 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
> 211:C 10 Jun 2019 03:15:11.972 # Redis version=5.0.4, bits=64, commit=00000000, modified=0, pid=211, just started
> 211:C 10 Jun 2019 03:15:11.972 # Configuration loaded
> 211:M 10 Jun 2019 03:15:11.973 # Could not create server TCP listening socket *:6379: bind: Address already in use
> I, [2019-06-10T03:15:13.974213 #14]  INFO -- : HEAD is now at 12e78d8 DEV: add wrapper for rspec running in docker
> 
> I, [2019-06-10T03:15:13.974282 #14]  INFO -- : > cd /var/www/discourse && git clean -f
> I, [2019-06-10T03:15:14.072380 #14]  INFO -- : 
> I, [2019-06-10T03:15:14.072448 #14]  INFO -- : > cd /var/www/discourse && git remote set-branches --add origin master
> I, [2019-06-10T03:15:14.075624 #14]  INFO -- : 
> I, [2019-06-10T03:15:14.075696 #14]  INFO -- : > cd /var/www/discourse && git pull

Are you already running redis on the server? That’s what ‘address already in use’ implies.

I wouldnt think so I’ve never touched redis before now so it should be the only instance running. How would I be able to double check this?