Error while running vagrant up


(Kpd Peiris) #1

I’m trying to setup discourse with vagrant, but fails with the below error. Please help me on this.

==> default: Importing base box 'discourse-16.04'...
Progress: 80%There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["import", "/home/kpdp/.vagrant.d/boxes/discourse-16.04/0/virtualbox/box.ovf", "--vsys", "0", "--vmname", "discourse_default_1464875804802_71522_1487047744224_21715", "--vsys", "0", "--unit", "11", "--disk", "/home/kpdp/VirtualBox VMs/discourse_default_1464875804802_71522_1487047744224_21715/box-disk1.vmdk"]

Stderr: 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Interpreting /home/kpdp/.vagrant.d/boxes/discourse-16.04/0/virtualbox/box.ovf...
OK.
0%...10%...20%...30%...40%...50%...60%...70%...80%...
Progress state: VBOX_E_FILE_ERROR
VBoxManage: error: Appliance import failed
VBoxManage: error: Could not create the imported medium '/home/kpdp/VirtualBox VMs/discourse_default_1464875804802_71522_1487047744224_21715/box-disk1.vmdk'.
VBoxManage: error: VMDK: Compressed image is corrupted '/home/kpdp/.vagrant.d/boxes/discourse-16.04/0/virtualbox/box-disk1.vmdk' (VERR_ZIP_CORRUPTED)
VBoxManage: error: Details: code VBOX_E_FILE_ERROR (0x80bb0004), component ApplianceWrap, interface IAppliance
VBoxManage: error: Context: "RTEXITCODE handleImportAppliance(HandlerArg*)" at line 877 of file VBoxManageAppliance.cpp

(Kpd Peiris) #2

Since I got the above error several times tried deleting the box file and downloading it again

But always getting the below error

An error occurred while downloading the remote file. The error
message, if any, is reproduced below. Please fix this error and try
again.

transfer closed with 268624943 bytes remaining to read


(Kpd Peiris) #3

I tried manually downloading the box file, but still failed with the below error

wget https://www.dropbox.com/s/2132770g1e05c6d/discourse.box?dl=1

--2017-02-15 11:17:26--  https://www.dropbox.com/s/2132770g1e05c6d/discourse.box?dl=1
Resolving www.dropbox.com (www.dropbox.com)... 162.125.82.1
Connecting to www.dropbox.com (www.dropbox.com)|162.125.82.1|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://dl.dropboxusercontent.com/content_link/mCILvh8b1peo7jsMUekng0NwxTMvaLzeWRp2jfVFjFdmfZGDT8Io8cvSuAbrEnKE/file?dl=1 [following]
--2017-02-15 11:17:27--  https://dl.dropboxusercontent.com/content_link/mCILvh8b1peo7jsMUekng0NwxTMvaLzeWRp2jfVFjFdmfZGDT8Io8cvSuAbrEnKE/file?dl=1
Resolving dl.dropboxusercontent.com (dl.dropboxusercontent.com)... 162.125.82.6
Connecting to dl.dropboxusercontent.com (dl.dropboxusercontent.com)|162.125.82.6|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1648550959 (1.5G) [application/octet-stream]
Saving to: ‘discourse.box?dl=1’

discourse.box?dl=1                        87%[======================================================================>           ]   1.34G   336KB/s    in 91m 42s 

2017-02-15 12:49:13 (255 KB/s) - Connection closed at byte 1434460160. Retrying.

--2017-02-15 12:49:14--  (try: 2)  https://dl.dropboxusercontent.com/content_link/mCILvh8b1peo7jsMUekng0NwxTMvaLzeWRp2jfVFjFdmfZGDT8Io8cvSuAbrEnKE/file?dl=1
Connecting to dl.dropboxusercontent.com (dl.dropboxusercontent.com)|162.125.82.6|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2017-02-15 12:49:14 ERROR 404: Not Found.

(Claas Aug.) #4

Maybe this workaround could work for you: