Failed to bootstrap 2

Pups::ExecError: if [ -z "$LETSENCRYPT_ACCOUNT_EMAIL" ]; then echo "LETSENCRYPT_ACCOUNT_EMAIL ENV variable is required and has not been set."; exit 1; fi failed with return #<Process::Status: pid 2068 exit 1>
Location of failure: /usr/local/lib/ruby/gems/2.7.0/gems/pups-1.1.1/lib/pups/exec_command.rb:117:in `spawn'
exec failed with the params {"cmd"=>["if [ -z \"$LETSENCRYPT_ACCOUNT_EMAIL\" ]; then echo \"LETSENCRYPT_ACCOUNT_EMAIL ENV variable is required and has not been set.\"; exit 1; fi", "/bin/bash -c \"if [[ ! \\\"$LETSENCRYPT_ACCOUNT_EMAIL\\\" =~ ([^@]+)@([^\\.]+) ]]; then echo \\\"LETSENCRYPT_ACCOUNT_EMAIL is not a valid email address\\\"; exit 1; fi\""]}
bootstrap failed with exit code 1
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one.

Nothing was up and this was the only error…! What is happening here??? Why does it have to be this much complicated??


You haven’t added a LETSENCRYPT Account email.

Try running ./discourse-setup again to reconfigure.

You were right bro and I realized that while reading over and over the message and I did set and email and things went smooth this time but page says;

Secure Connection Failed

An error occurred during a connection to PR_END_OF_FILE_ERROR

  • The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.

  • Please contact the website owners to inform them of this problem.

What to do now with this on the front page of my

I think that’s not a Discourse issue.

How many times did you try to rebuild this instance?

Have you tried a different browser to Firefox?


I’ve been trying several times with same error message!!

Ohhhhh, I get it :roll_eyes: It must be the SSLs I pulled giving wrong output!

So, how long do I have to wait for this to clear out and things work out normal?? :stuck_out_tongue:

Thanks for bringing it to my attention dude! +1 rep added :slight_smile:

I think it’s a week. If you’re not in love with your subdomain, and you get your DNS right, you can just try again on the new subdomain.


Not really :smiley:

If I can get that subdomain in a click and done everything related with it. Can I then just change/ replace the yml setting only with new hostname, smtp, and email … etc?? Would it work and site will be up and running once app rebuilt??? I’m guessing yes, but need to ask an expert to believe :eyes:

Pretty much, although there are some post rebuild steps for existing communities which rename.

1 Like