Gamification shows 404 to all users but admin

At leaderbord if Visible to groups is everyone (I think it is everyone but in finnish it is kaikki — same thing) all other users but admins gets error 404 (oops… not found or deleted…).

If I change everyone (kaikki) to trust levels everything works.

So — I would call it a bug, or do I miss something?

I don’t know how things are working but I have had issues earlier somewhere because of translated group names, as admin, moderator etc. Can this be an issue now?


I forgot… the leaderboard worked at the time we got ability exclude groups. So, something has changed after that update — but when… not a clue: the leaderboard isn’t that popular among my users.

1 Like

If there may be a translation issue, it would be helpful to see screenshots, so we may compare what you are seeing. :mag: :+1:

1 Like

First I was what the heck what’s wrong with screenshot I attached and then I was just :flushed: :man_facepalming:

I’ll edit original… just a second or two.

Can you please share a screenshot of the whole leaderboard config in English were the problem occurs?

1 Like

Groups follows language of the site, not language of interface — as you all knew, I reckon.

BTW — some update has cleaned date range too. Not so important, but interesting.


Just to be more clearer :wink:

  • if a leaderbord is visible to kaikki (in english everyone) only admins can see it
  • if a leaderbord is visible from luottamustaso_0 (trustlevel_0) to luottamustaso_4 (trustlevel_4) everyone who is logged in sees it

So the issue is kaikki/everyone — and that is ment to be ”just” nice UI thing in the first place to make setting up faster and easier, I guess.

I can live with Tl0 … TL4, though.

I’ve just been attempting a run-through of this on my test site, and I believe the specific English equivalent is ‘Everyone’. I have set up a new leaderboard and set it to be visible to ‘everyone’ but when I try and access it with a TL1 test user it comes up as an ’ Oops! That page doesn’t exist or is private.`

(There’s also a double ‘the’ in the setting description)


Thanks — I changed all to everyone; perhaps my texts are a little bit confusing then :joy:


I have just added a fix for this.

This will block admins from selection everyone on the config screen. Also updated the copy there to reflect the change.


This topic was automatically closed after 3 days. New replies are no longer allowed.