Getting error when setting up Let's Encrypt SSL on GCP

I am trying to setup Lets Encrypt SSL, so while installing discourse, I tried setting the email for Lets encrypt but I got below error :-

Checking your domain name . . .
WARNING:: This server does not appear to be accessible at
A connection to (port 80) also fails.
This suggests that resolves to the wrong IP address
or that traffic is not being routed to your server.
Google: “open ports YOUR CLOUD SERVICE” for information for resolving this problem.
You should probably answer “n” at the next prompt and disable Let’s Encrypt.
This test might not work for all situations,
so if you can access Discourse at, you might try anyway.

The above is the error message from discourse install, there might be anything missing in my GCP config.
I installed without SSL now but can anyone tell me what might be the issue

Your discourse server is not at Click the link you included.

You’ll need to update your DNS to make it point to your discourse server.

If there is something that could make that message more clear, please suggest it.

1 Like

Hi Jay,
that is an just an example link

Then it’s impossible to diagnose.

Is it the case that your DNS does point to your server and the ports are open?and you can access discourse with your hostname? If so, you can ignore those warnings

And see what happens. I don’t know under what conditions the test the script does might fail to connect to itself, but there could be some.

Hi pfaffman,
I am able to access my domain and see the Congratulations page on discourse in http scenario, only thing is I get Error host not found if I try to access the account activate link. But this is a different issue.

Now regarding the original issue, I pasted the exact message from discourse install. I updated my first message so that it is better disguised. Sorry for confusion, but the above error mentioned in first post only appears if I try to setup Lets Encrypt email in discourse install. I am currently not having SSL certificate installed, so do you think that might be the problem ?

I suspect that is the same issue.

If you can’t share your domain name, I can’t help.

One possibility is that you have two A records.

Hi Jay,
I do have two A records, one is www and one is without www in GCP.
Should I delete www ?

I mean that you may have two A records for your hostname. Only the hostname that you put in app.yml is checked by the script.

If you think your DNS is right you can try enabling let’s encrypt. The evidence that I have is that you have something wrong.

Ah, hostname was incorrect :slight_smile:
If I just rename the hostname, it should work pfaffman or I need to use launcher ?

1 Like

Just run disourse-setup again.

1 Like

For other people who see this in the future and have the same problem.
I had to enable the port through firewall on Ubuntu
sudo ufw allow 443/tcp