Google maps embedding broken in 1.8.0.beta8


(Gustavo Niemeyer) #1

Looking at the HTML generated, there’s a transparent <div> right above the map iframe that is overlaid on top of the map:

Removing that div in the debugger makes the map work fine.

Confirmed broken in Firefox 52.0 and Chrome 56.0, with several different URLs.

Some more background: I cannot reproduce this on another category. The bug happens under Staff.

Nevermind… I don’t know why it worked once. It consistently doesn’t work now.


(Gustavo Niemeyer) #2

Hello… anyone around here? :slight_smile:


(Gustavo Niemeyer) #3

Probably not… if anyone else has this issue, you can workaround it by creating a custom CSS via the admin interface and using the following there:

div.maps-onebox > div:first-child {
    z-index: -1;
}

You enter this both in the first tab and in the mobile one. Save, enable, and be happy.


(Robin Ward) #4

Testing a maps embed:

Confirmed there is a transparent div that prevents interacting with the map. Any ideas @zogstrip or @techAPJ?


(Joshua Rosenfeld) #5

This background might be useful:


(Arpit Jalan) #7

This issue was because we recently pushed a security change in which we sanitized the onebox output HTML. Previously that transparent div used to have onClick="style.pointerEvents='none'" attribute but now it’s getting removed by sanitize gem. It seems like sanitize gem does not support whitelisting of onClick attribute.

For the time being I fixed this issue by removing the transparent <div> on top of iframe.

I will see if we can workaround this to add the transparent div back so that Google Maps onebox does not interfere with page scrolling.


(Arpit Jalan) #8

This topic was automatically closed after 2 days. New replies are no longer allowed.