Google My Map embedded link in Discourse posts

Hello! Recently, I have been trying to embed a Google My Map link into my post on a Discourse community, and this should show up (this was embedded into a few months back)

However, when I tried embedding it into a post today (with the same link I used to embed it above, nothing changed), I was unable to do so. I have also tried this out on other discourse communities, but all I get is the below:

As you can see, it’s a blank square with nothing showing up. Is there any way to fix this?

Have you tried adding that address to the allowed iframes in security settings?

You will need to contact the admin of the target site and request this is added if you do not control the site yourself.

1 Like

Yes, it is, but it’s not working.

1 Like

Same problem here… added to allowed frames and rebaked but still a no-show. It is reproducible here:

is a no-show of Transport in Dubai (click to expand) - Google My Maps

I think you’ll need to add “” as allowable, as it’s being blocked - the source in the post is showing it as.


Thanks Paul, that did it! I looked at the source but missed that the URL changed from ..viewer to ..embed.