How do I manually update Discourse and Docker image to latest?

(Rafael dos Santos Silva) #107

With the 1.8 release, we are now requiring a new update of the base image, which includes (among many stuff) Ruby 2.4.

(Simevo) #108

Is moving to Ruby 2.4 not too hasty ? It seems it’s not in ubuntu yet

(Sam Saffron) #109

Ruby 2.4.1 is the stable release of Ruby per Ruby Programming Language

Xenial ships with 2.3.1 Ubuntu – Details of package ruby2.3 in xenial-updates , Ruby 2.3.4 was just released, it includes fixes for potential segfaults like this:

This is one of the many reasons we use Docker for our distribution.

(Christoph) #110

This opens up an interactive configuration dialogue which is not a big deal but I am somewhat unsure about whether I should simply accept the default values here:

I know that ubuntu (I’m running 16.04) builds on debian, but still, is debian supposed to be there?

(fearlessfrog) #111

At the docker update stage but want to check what to do first. Here’s where I am (I think the first the upgrade page leads to here is out of date?):

 Ubuntu 14.04.4 LTS

> git pull
Already up-to-date.

> ./launcher rebuild app
ERROR: Docker version 1.9.1 not supported, please upgrade to at least 17.06.2, or recommended 17.06.2

So looking up at first post that leads me to:

> apt-get update

> apt-get dist-upgrade

> apt-get install lxc-docker- docker-engine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package docker-engine

Ok, so via some archeology in the topic above, I go here: New Apt and Yum Repos - Docker Blog

…and do the following:

 > apt-key adv --keyserver hkp:// --recv-keys 58118E89F3A912897C070ADBF76221572C52609D

> vi /etc/apt/sources.list.d/docker.list

…where I change this…

deb docker main

to this:

deb ubuntu-trusty main

Do my apt updates again but get to this point:

./launcher rebuild app
ERROR: Docker version 17.05.0-ce not supported, please upgrade to at least 17.06.2, or recommended 17.06.2

So did I do the above incorrectly or should I be trying to fetch a specific version of Docker (how?)?

End of Life for Ubuntu 14.04 Trusty and Discourse 1.9.0.beta10?
(Dean Taylor) #112

This came up earlier today and seems to be fixed:

Basically complete a git pull and ./launcher rebuild app again which should get you the fix.

Quotes pointing to deleted post gets stuck loading
(fearlessfrog) #113

Thanks for the response.

I think I am at latest and still no joy (same as above). I have that update to launcher already, and can see the comment to stackoverflow in it.

Is the issue that I am at 14.04.4 LTS and that docker-engine is latest at 17.05.0-ce on Trusty? As in, should I be looking at updating Ubuntu at this point?

EDIT: Was just an older docker-engine rather than docker-ce install. Updated as per End of Life for Ubuntu 14.04 Trusty and Discourse 1.9.0.beta10?

(fearlessfrog) #114

I updated the first post wiki to include the info about updating docker from previous packaging, as the info was deprecated I believe. It still probably needs a grown-up like @sam to look over my edits. but hopefully it helps as the web updater links to this topic.

(Jay Patel) #115

I am getting same error… still not solved after doing git pull

(Dean Taylor) #116

The first post in this topic has been updated in the past couple of days you may want to re-read the post and sure you have followed those instructions:

(Anton) #117

How do I update docker from

Ubuntu 16.04.3 LTS

When I run ./launcher rebuild app, it says:

ERROR: Docker version 17.05.0-ce not supported, please upgrade to at least 17.06.2, or recommended 17.06.2

However, when I run apt-get upgrade lxc-docker- docker-engine, it makes no updates.

Finally, when running wget -qO- | sh, it shows me the following warning, I’m afraid to proceed:


What’s the best course of action in my case? Please advise.

Issue with sending a message to a private group
(Dean Taylor) #118

Only you can answer the question from your own screen grab:

If you installed the current Docker package using this script and are using it again to update Docker, you can safely ignore this message.

If you followed the Official Discourse Beginner Docker Install Guide here, those instructions included the use of the same script so you can very likely ignore the message and allow it to update.

(Anton) #119

… well, I installed it a few years ago, and I think the official guide was different then. I can’t remember.


Here is what I did:

  1. sudo apt-get remove docker docker-engine - this removed existing docker-engine.
  2. Installed docker via command outlined in the very first message of this topic.
  3. Run ./launcher rebuild app

All worked well.

(Jay Patel) #120

I actually didn’t manually installed discourse. I chose digital ocean’s one click install … Should i still follow same steps? Or need to change something else?

(Joshua Rosenfeld) #121

As we (the Discourse team) did not make the one-click install it’s impossible to say with 100% certainty, but I’d say go ahead. If your extra worried, download a backup.

(Jay Patel) #122

Thanks … Latest git pull has included solution to upgrade.

(Lea-Ann McGregor) #123

sounds like greek to me! who did I hire to do my install? and how much does it cost to have you do the update or give me step-by-step instructions on doing it myself?

(Joshua Rosenfeld) #124

Hi Lea-Ann!

Do you have a Discourse site already and need help upgrading, or are you looking to setup a brand new site?

(Lea-Ann McGregor) #125

I have a discourse site already that needs the manual update done.

(Joshua Rosenfeld) #126

OK. I’m happy to direct you to a consultant who you can pay for assistance, but I’d also be happy to help you run the update yourself. Let me know which you’d prefer.

If you would like help running the update yourself, did you install your site personally, or did someone else manage that?