How long before version 2.5.0.beta5 becomes unusable?

Hi all,

This is Tommo, and I recently started working as a moderator in a forum that uses Discourse.

As the title suggests, our Forum currently uses version 2.5.0.beta5 which is fairly old. We are certainly planning to update in the future but currently don’t have enough time / knowledge to do the update confidently.

So… how long can we keep going with 2.5.0.beta5, without compromising the basic functionalities of the Forum?

Many thanks in advance for your help!

Tommo

1 Like

Well, as long as it works, it’s usable. But there have been a couple of security fixes since then, so you are essentially running an unsupported, insecure version of Discourse. I’d update as soon as possible.

(I took the liberty of removing the link to your forum as I think it’s unwise to advertise its location in your case. :wink:)

7 Likes