Do I need to upgrade to version 1.8.0.beta11?


(Wiliam Joaquim) #1

I just installed the discourse, the first update was done automatically, but then has another update to version 1.8.0beta11, and it’s by SSH, I got to do, but the site stopped working, and I installed again, now I’m in doubt, Is it really necessary to upgrade? Or could this version v1.6.0.beta1 +140 always stay with it?


(cpradio) #2

If you just installed Discourse, why are you on version 1.6.0? That is definitely not a safe version to be on.

What process did you use to install Discourse?


(Wiliam Joaquim) #3

I installed with the DigitalOcean tutorial, and as soon as I entered the admin, I requested the upgrade, and I installed it, what is dangerous?


(cpradio) #4

Can you give us the link to said tutorial? As 1.6.0 is very old. The latest stable version is 1.7.8, there are many security updates since 1.6.0, so I’m not sure how you got that version to begin with.


(Wiliam Joaquim) #5

I followed this tutorial discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub how do I go to version 1.7.8?


(cpradio) #6

If you followed that tutorial, you can’t possibly be on 1.6.0, is that a typo? Can you indicate where you see that version being mentioned in your install? You have to be on 1.8.0.beta11…

Right now you will be on tests-passed branch (the default). You will likely see that updates are available on a daily basis, but you need not worry about that. When the new stable version 1.8.0 is released (probably in a couple more weeks, maybe a month?), you can update your app.yml and replace tests-passed with stable and do a rebuild.


(Wiliam Joaquim) #7

Is the version 1.6.0 that I have, should I wait for version 1.8 or redo the installation?


(cpradio) #8

Can you screenshot the /admin area where it displays the installed version and latest version in the dashboard?

I just can’t fathom how you got it to install 1.6.0.


(cpradio) #9

Welp, he PM’d me a screenshot showing 1.6.0 was the version mentioned as installed. I think he is going to try to do a clean install to see if it happens again.

@Wiliam_Joaquim, after running ./discourse-setup you didn’t alter your app.yml by chance did you? You left it alone?


(Julian Muñoz) #10

Maybe he followed this tutorial which seems dated? The One Click App at DigitalOcean says “Discourse on 14.04” which could explain why he has 1.6.0


(cpradio) #11

@Wiliam_Joaquim, did you have any success with a new clean install?


(Wiliam Joaquim) #12

Yes, I used this option


(cpradio) #13

Oh, that changes things entirely, as it is using a One-Click Image, which is likely coming with Discourse 1.6.0 already on it.


(Wiliam Joaquim) #14

No, I tried to install without using a Digital Ocean one click, but when I run the ./dicsourse-setup command the installation does not finish and SSH ends up inactivity, I decided to leave version 1.6.0


(Felix Freiberger) #15

This means that you will be running a version with multiple significant unpatched security issues :warning:


(Wiliam Joaquim) #16

I understand, but I tried to install the clean version through PUTTY, but when I run the ./discourse-setup command, the execution is stopped, I leave it for minutes and nothing happens, it is stopped for so long that the server disconnects, which can to be?


(Felix Freiberger) #17

Try running this in sreen or tmux, so it won’t be interrupted when your network disconnects.

Short tmux-based guide:

  1. SSH into your server.
  2. run tmux
  3. you will get a new shell, start the rebuild in here as usual

If you’re disconnected, reconnect and run tmux attach-session and you’ll be right where you left off :slight_smile:

Please give this step at least 60 minutes to complete. (It usually is faster, but definitely is the slowest step.)


(Wiliam Joaquim) #18

I will try to install again, before deleting discourse 1.6.0 I tried to upgrade to 1.8.0beta, (I was asked) I used these

cd / var / discourse commands
Git pull
./launcher rebuild app

As recommended, but the site went out of the air, is it normal? If you come back, is this version still unstable?


(Wiliam Joaquim) #19

I did as you recommended, it is not always local, and nothing happens, have more installation files after that? Or right there? If I send SSH access did someone try to install it? I’m 3 days and I can not, I need the speech installed a lot :chorar:


(Felix Freiberger) #20

It’s normal for your site to be offline during the rebuild, yes.

Sorry, but I don’t understand the rest of your posts :frowning:

Maybe try asking in your native language? Meta has a pretty diverse community :slight_smile: