How to prevent another log in with Auth0 and OAuth2 Basic Plugin

I have managed to successfully connect Auth0 to my discourse forum.

However, it is not working as planned.


1 - User logs into our webapp at with auth0
2 - User navigates to
3 - User has to click “log in” again
4 - User is automatically logged in without having to fill in the details again

I am looking for a way to skip step 3.

In other words, when the user logs into our webapp on and then navigates to, I want them to automatically see the content and not have to click “log in” again.

The only way to have that working is by changing login_required to true in the site settings, but that will make your forum lose anonymous access, google bot crawling, etc.


I have done this, and the user still has to click “log in” - which automatically logs them in

Oh, when using OAuth2 instead of DiscourseConnect you also need to check the setting auth immediately .


I have also got that enabled :unamused:

Could it be an issue with the fact that users auth at, but it is not authenticating with the subdomain

Could issues be caused if they auth with then go to

Nope. Have you disabled every other auth method? If auth immediately is broken that is a bug we must fix.


Yep, local log in is disabled. Only oauth2 is enabled.

Can you share the site URL ?

Sent in direct message

It’s already working for me:



1 Like

What do you mean sorry?

What would I need to adjust to get this working?