Incoming e-mail not received

step 1) can you log into the mailbox and confirm that the mail there ?

step 2) is your pop3 settings saved in admin > settings

step 3) the email address in enter in the category > settings > email section

3 Likes

I think the mail-receiver needs manual polling rather than pop3:

1 Like

Yes. I can confirm that I have enabled manual polling via the admin interface. I should not have to do a rebuild after that right?

Anyway, the result (or rather lack thereof) is the same unfortunately.

1 Like

did you follow my steps ?

1 Like

As you’ve got the Feb 09 08:54:24 ubuntu-mail-receiver postfix/master[1]: daemon started – version 3.5.6, configuration /etc/postfix log, but you don’t get a rejected email, it makes me think the problem could be in the DNS section of the guide.

Hi Gavin,

I do not use pop3 but the incoming e-mail server as described here: Direct-delivery incoming email for self-hosted sites

Regarding your 3 steps:
1 there is no mailbox so I cannot login to it, the mail should be directly picked up by the service in the additional container right?
2 is set manual polling (instead of pop3)
3 not sure i quite understand this step

Thanks,

Justin

I think that step is for creating topics by email.

1 Like

Ok then I think I do not need step 3 for now.

What more is there to check dns wise if the mxtoolbox check gives the right IP nr for the mail domain?

Apart from checking over your DNS MX records manually (and double checking the guide), I’m not sure. I’ve only set the mail-receiver up a handful of times, and it’s been pretty plain-sailing every time (not to rub it in). When I check the mx:community.mountainbikemuseum.net mx record it says its not the fully qualified domain name, so I can’t tell if the mx records are pointing to the right place. (Edit: I put a www. in front :slightly_smiling_face: It’s inconclusive, but looks similar to my working one. I’ve sent a test email to it just on the offchance)

@IAmGav may be on to something that I can’t spot, so hopefully he can give you a bit more detail about those steps.

Just to confirm, you’re the OP with another account?

I’ll throw in a link to the Troubleshooting section for good measure. :crossed_fingers:

1 Like

I just set this up myself and mine is working.

I activated 2 settings in settings > email

  • manual polling enabled
  • email in

check those 2

Yes, I forgot I already created my account with my GitHub login, so now I have 2 accounts, I will delete the other one.

I think it might be a firewall Issue. Do you know which ports should be opened for incoming traffic, 143 for IMAP?

you dont setup pop3 or imap for this.

Having a little search, it seems to suggest the mail-receiver uses port 25, and that some providers can block this. It’s also possible you have something else interfering. I’m afraid I don’t have much experience of this though. Is there anything unusual about your set-up?

It is solved. I managed to create a different thread in the process :face_with_monocle:

https://meta.discourse.org/t/re-incoming-e-mail-not-received/217717/4?u=justinvolved

That’s great. :+1: I can’t access that topic - do you mind sharing what the problem/resolution was?

It was the firewall, after I opened up SMTP the e-mail comes in. So if not for the firewall it was indeed a very smooth install :slight_smile: Thanks for the help!

2 Likes

I shall remember that for if it crops up again. :slightly_smiling_face::+1:

Is there anything that could be added to the guide that would have made this less painful?

I think in the troubleshooting section at point 2
Did the e-mail even make it to mail-receiver ?
It would be nice to add a line to check if there is a firewall that blocks incoming smtp traffic, ideally maybe even link to something describing the exact ports that should be open. (I have a firewall config panel that automatically adds 25, 587 and 465, but would be nice to know what the mail-receiver is actually listening on)

1 Like

That’s likely it.
25 for smtp

I have added a line to the wiki guide. :+1:

2 Likes