Install Discourse Docker on Ubuntu 11


as I know it is pretty difficult / not possible to install Discourse on Debian 11.
I have managed it to install on 10.5, but now, no matter how I try no access in the webGUI and no mail after the build-process.

I have tried more tutorials e. g. this one: How To Install Discourse with Docker on Ubuntu 18.04 |

Can somebody confirm if it is anyhow possible to access Discourse after install process?

Docker Container is active and also ./discourse-setup run thru …

launcher seems not to work:

./launcher logs app gives an error.

Any idea?


Have you tried following How to install Discourse in production. As long as you can install Docker, Debian <anything that works> should work just fine.

EDIT: I assumed you meant a production install. But perhaps I’m wrong.

i would suggest you follow the below instead of the url you provided

Thank you for your answer …

According to the log teh error has been caused by the default activated cert:

letsencrypt.ssl.template.yml enabled
Unfortunately, there was an error changing containers/app.yml

It is however not activated in the yml file:

Is there any other configuration where the SSL certificate could be deactivated?

After adding a mailaddress as lets Encrypt Mailadress to the config the rebuild process went thru.
Despite of it I cannot access Discourse …

That is not true, Discourse in Debian 11 works just fine provided you can follow the official install guide.

1 Like

I have finally found the two lines in the configs which have to be deactivated. (as still do not have a certificate to actively use.)
After rebuild I can access Discourse.

You probably ran it a bunch of times so that you hit let’s encrypt’s rate limit. I recommend that in a week you re-activate those lines and rebuild so that you’re HTTPS enabled. Some things won’t work without https.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.