Is there a way to keep certain categories activity off from latest and top?


We have a number of categories that are private because we don’t want activity in those categories to affect the rest of the activity in the site. These private categories are topic specific and shouldn’t be visible to other members who didn’t choose to join the discussion.

Because of the recent bugs with the invitation links, we might consider to temporarily open these categories instead of keeping them private; however, we can’t do that unless there is a way to keep the activity in these categories ‘muted’ from the rest of the site i.e. new posts and topics should not appear in the top, recent, or latest pages/columns.

Please, is there a way to keep activity in certain categories off from the rest of the site (latest, top…etc)?

Thank you!

There’s the default categories muted admin setting which should achieve this. :+1: It will mute those categories/topics for anyone that isn’t tracking or watching them.

1 Like

Is this going to hide the category from the homepage, stop topics from appearing in the ‘recent’/‘top’/‘latest’?

And even if it did, that’s an issue because we don’t want that setting for all categories, just certain categories.


I think it will do all of these things, and you set it per category so you only put the ones you want in there:

1 Like

Thanks! It might be a temporary solution until the invitation links bugs are fixed.

I need to make sure the categories will not appear in the category list and in the homepage…etc Is there a reference for this feature? update: First test, the sub-category still appears in the list of categories as well in the homepage even after adding it to ‘default categories muted.’

Plus, I’m afraid if it doesn’t work for the subcategories? Is an actual bug? Please see reported bug here: (Default categories muted for subcategory not working)

1 Like

Ah, that may not be so useful to you at the moment then. :slightly_frowning_face: I’ll give it a run-through and see if I repro. Thanks for the push to check it out. :+1:

@gassim - I’ve just tried to replicate the issue, but it is working as expected for me:

How are you testing the visibility on your site? Could you run through the tests in the other topic and see if you’re getting different results?

1 Like