Localhost:3000/users gives no-results


(giorgia) #1

I install my local version of discourse which seems to work pretty fine.
I have an admin user and i created other 2 test users, which i can see the profile and i can see when i search for them in the search bar.
Anyway if i go to /users i got No results were found

Any suggestion how can i check why is this happening?

I run discourse without Vm, with normal instalation following this guide


(Rafael dos Santos Silva) #2

/users is filled trough a background job, ran by Sidekiq.

There are instructions to run sidekiq if you want at the very end of the dev instructions


(giorgia) #3

I installed the gem mailcatcher
but if i run ruby $(mailcatcher) i get ruby: No such file or directory -- Starting (LoadError)

I’m on OS Sierra and rbenv version give 2.3.0

And doing ruby -v give also the current version


(giorgia) #4

Still not sure why i got that error with ruby directory but look like i need just bundle exec sidekiq -q critical,low,default -d -l log/sidekiq.log to display /users

so my problem is postponed to the time i will need emails :stuck_out_tongue:
Thanks @Falco!


(Blake Erickson) #5

Try running just mailcatcher command from a directory other than your discourse directory.


(giorgia) #6

i got

rbenv: mailcatcher: command not found

The `mailcatcher' command exists in these Ruby versions:
  2.3.0

Do i have to install mailcatcher globally?


(Blake Erickson) #7

Yes.

https://mailcatcher.me/