Manual Backup not starting


(TJO) #1

Hey all -

After the update to v1.3.0.beta3 +17, executing a manual backup in the GUI isn’t doing anything. The popup for “include images” etc, doesn’t show up. Running on Ubuntu 14.04.2. 1G RAM / 1G Swap.

My upgrade was via the CLI - cd /var/discourse ; git pull ; ./launcher rebuild app

No errors seen.

Plenty of disk space (19G avail) and this is what I’ve tried:

  • stop app
  • start app
  • rebuild app
  • reboot(s)
  • apt-get upgrade to the latest
  • restart app
  • another git pull (Already up-to-date.)
  • cleared history / cache etc

I can, however, upload and delete old backups via the interface. I pulled a backup right before the upgrade; I have not attempted a restore.

In the (GUI) logs screen, I have:

No logs yet…

This is on EC2 – and I run a ‘test’ site, so to speak, on a Parallels VM at home – and it seems to be fine - upgrade done the same way, except it was done on 3/11, it does say +17 as well. I’m testing in a tab, right beside the ‘problem’ site - and the backup works just fine.

I’m at a loss.

Any thoughts? Did I miss something stupid?

Thanks!


(Régis Hanol) #2

Sorry about that. I missed that modal when refactoring the modals to ES6 syntax. I just pushed a fix :bee:


(Régis Hanol) #3