Markdown Parser Altering Quoted Text


(Christopher Stone) #1

Hey Folks,

I just noticed this while writing a reply on the Keyboard Maestro forum.

Item 2 below is written:

2. It seems that I don't have to specifically exclude background apps (e.g., Dropbox, Hazel, Alfred, etc.). It appears that those continue to run. Is that the expected behavior?

It is clearly prefixed with a “2. ”, but Discourse is changing it to a “1. ”.


Original Text:


Specify exactly what apps are failing to quit.


-Chris


(Jeff Atwood) #2

That is how markdown works. Feel free to read more about it at http://commonmark.org


(Eli the Bearded) #3

This is one of my biggest gripes about Markdown. Put a backslash between the number and the period to disable that.

2001. A year for a *Space Odyssey*

  1. A year for a Space Odyssey

2001\. A year for a *Space Odyssey*

2001. A year for a Space Odyssey