MathJax plugin could not find module discourse/lib/load-script


(Christopher Olson) #1

In my installation of Discourse, MathJax is broken. I think that’s probably due to “Could not find module discourse/lib/load-script”. Things were working, and I cannot be sure when they broke, but I suspect it happened when I upgraded to Discourse to 1.2.1 and MathJax to 0.4.1.

This is the full error message I’m seeing with Chrome:

To fix this, I tried:

  1. Double checking I’m up-to-date on everything.
  2. disabling and reenabling the MathJax plugin.
  3. Rebooting, naturally.
  4. launch app rebuild

What else might I try?

I think the install is pretty standard. I followed the instructions to install with Docker on DigitalOcean from before the 1.0 release, and I’ve always upgraded via the Admin panel since then.

If needed, the issue can be seen here.


(Sam Saffron) #2

MathJax now have a dependency on latest stable Discoruse.

Either, move to tests-passed

Or, in the container definition pull an old version of mathjax, or fork it, or ask mathjax maintainers to introduce a branch for old.


(Christopher Olson) #3

Now I’m confused. I’m on Discourse 1.2.1, and my dashboard says that I’m up to date. Do you mean that 1.2.1 is not the latest stable version?


(Sam Saffron) #4

Sorry, I mixed up my terms:

you want to be on tests-passed.


(Kane York) #5

I think that beta has the dependencies he needs.


(Christopher Olson) #6

That fixed it. Thanks Sam!


(Sam Saffron) #7