Mixed Content: The page at '<URL>' was loaded over HTTPS error

How do I fix this error displayed in the browser console?

Mixed Content: The page at '<URL>' was loaded over HTTPS, but requested an insecure element '<URL>'. This request was automatically upgraded to HTTPS, For more information see <URL>

Something on you site is referring to an asset with http, probably. It might be an image. It might be that a theme component is doing it

You should be able to tell in the network section of the developer tools.

1 Like

Should the force_https setting be on? When I turn this setting on, the site crashes.

The problem is in the svg file. The extension of the site logo is svg.

So you’ll need to change that to point to https.

The force https should be set automatically, but if it’s crashing your site then you may have other issues.

I may be very wrong but that reminds me something. You can try removing your logo, then reuploading it so the full url may be updated.
The force https settings has be gone from the interface settings many versions ago though… :face_with_raised_eyebrow:

(I’ll remove my message if it is nonsense to avoid misleading people using the search)

That’s because the standard install sets it in an environment variable (except for a time last fall when it was broken).

Has this site been rebuilt lately? Is it a standard install?

1 Like