Model in Topic title connector is undefined - Ctrl+enter to save topic title edits


(Net Deamon) #1

Earlier, in the topic-title connector, the model variable used to be set which had the details for the topic.
But now the model is undefined.

So I went through the commits made for topic-title.hbs file, and I tried removing/adding the commit to understand the changes.

Here is the screenshot of the model in the topic-title connector.

Here is the model present in the topic-title.hbs connector before this commit (df213639f15e6e2df3de59a025145da77f503abd)

After this commit, the model object is undefined

So I want to understand the changes, is there any different way now we have to use the connector and the model present in it. I tried searching in github and meta, but I couldn’t figure out myself.


(Net Deamon) #2

I solved the issue by using the connector topic-above-posts instead of topic-title.
But I am still not sure why did the topic-title stopped working… I saw the changes in the git, where the topic.hbs was broken into several components… still it didnt make me understand why would it not work as before.


(Net Deamon) #3

Hi @eviltrout,
Do you think this is a bug, or am I doing something wrong?


(Robin Ward) #4

It does look like a bug to me. Try the following commit. I think it will fix it:


(Net Deamon) #5

Hi thanks for the commit, its working now :slight_smile:


(Robin Ward) #6