Moving old posts triggers email notifications

Moving old posts to a different category triggers email notifications for anyone watching that category. I need to do a bit of re-organization at my site, but it’s going to be confusing to folks if they receive notifications for these old posts. Is there I way I can temporarily disable this behavior while I’m moving things around?

i think you looking for this setting

create revision on bulk topic moves

2 Likes

That didn’t work for me? I turned it off, moved a topic, and the ‘watching first post’ user still got a notification. Is there anything else I needed to do?

Edit: I had a brainfart, and didn’t do a bulk move. I’ll try again. :slightly_smiling_face:

Update: It still sends the watching first post notification when I use the bulk move too? I’ve tried a few times and I can’t seem to figure out what I’m doing wrong?


I had to do a similar thing a small while back, and I went old school and put a notice up saying that I was moving/going to be moving a chunk of topics from one category to another, and that people who were ‘Watching First Post’ may get a few spam-like notifications. I was hoping it would give people a chance to change their category notifications (or just be aware and ignore them). It wasn’t so bad, though a couple of people missed the notice and were a little confused.

Looking at it again now I know more about the admin settings, it may be possible to default the category notification in the admin settings to normal muted, which would stop the watching first post notifications - but I don’t know how you’d ‘reset’ it to what it was before once you’d finished?

There are a few tips in this older post that might be useful:

3 Likes

Same here. I had create revision on bulk topic moves disabled when email was triggered.

2 Likes

I haven’t tested it but the disable category edit notifications setting looks promising.

5 Likes

I forgot that existed. :slightly_smiling_face:

I’ve just tested it, and it does not send a notification. :+1: (bulk move, or regular recategorise)

4 Likes

That sounds like the right setting, thanks!

3 Likes

You might want to mark @Simon_Manning’s post as the solution, so the answer shows up properly in the OP. :+1:

2 Likes

Thanks for catching that!

2 Likes