Need Help Troubleshooting an "Internal Server Error" message When New Topic is posted

Hey guys. Since I upgraded our Discourse instance v2.2.0.beta5 +35 (or possibly after I tried to update the subscription settings for the general category I’ve had some reports from users that they intermittently get an "internal Server Error Message when posting a new topic… Of course, I haven’t experienced this yet myself.


At this point I haven’t been able to isolate any variables or commonalities that these users might have.
At first I took a look at top, and it looked like the server (Two cores) was busy, but I would have thought it had enough overhead.


Here’s my error logs for today:

So I rebooted the server, users still report having the same issue, but CPU utilization is minimal

This was a bug that was fixed as per NoMethodError in force_edit_last_validator

Updating again will fix the problem.


Thanks so much. I’m not sure how I missed that, I searched I promise.

To update do I just run ./launcher rebuild app?
I’m not being prompted that an update is not available via the admin panel.


You can do that, or manually visit <forum>/admin/upgrade


Don’t stress, I say this ALL THE TIME. :slight_smile:

In the future, searching for a more specific string will help - Internal Server Error is VERY generic, but you can find good terms to use as your search key from the error you posted:

searching for undefined method posts "force_edit_last_validator" would have done the trick!


Oh for sure. I wasnt sure which line(s) (if any) in the logs pertained to the issue. But in retrospect I could have tried various lines and seen if I got any hits.

1 Like

:+1: The more you do it, the better you get at figuring out how to do it.

Turning off everything except Fatal is also a good place to start:



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.