Nginx page instead of Congratulations page

I followed these 30 minute instructions:

I am able to TelNet a successfull login to my smtp server.

My subdomain redirects properly to the IP that DigitalOcean assigned me ( 167.172.31.228 ).

But whenever I go to that IP, I get the Nginx page and not the Discourse Congratulations page :sob:

I have app.yml set up for https…

My smtp, letsencrypt and my ‘rails r "SiteSetting.notification_email’ email addresses in my app.yml are the same, but do not belong to the domain of the DISCOURSE_HOSTNAME.

I has been well over 30 minutes now, any ideas what has happened :question:

Thanks in advance for any help you can think of on this one :slight_smile:

1 Like

It should not redirect you, it should resolve. So if your domain is https://example.com, that should show in the address bar. Perhaps your DNS record is wonky? Check it out. :slight_smile:

This is all I have for options in the Subdomain setup with GoDaddy cPanel:

The ‘Manage Redirection’ only allows me to change the IP address of redirection…

Any ideas?

EDIT: May this issue have to do with https, I am very new at that .

Google "Godaddy create a record "

1 Like

Thanks, that finally gave me the clue that ‘A’ records are a thing :slight_smile:

I had already been to that top link of that Google search yesterday (EDIT: It turns out that link is only relevant to Windows hosted sites :frowning: ). In my defense, I discounted this link as I thought I had followed the 30 minute instructions as literally as I could.

The 30 minute instructions currently say:

  • Create a DNS A record for the discourse.example.com subdomain in your DNS control panel, pointing to the IP address of your cloud instance where you are installing Discourse.

The line breaks, on my screen, put that capital A as the last character on the line. Then, my brain simply skipped seeing the A. As a DNS newbie I did not know of the existence of ‘A’ records nor did I understand the difference between ‘pointing’ and ‘redirecting’.

Any chance that a moderator, reading here, can edit the 30 minute instructions and put single quotes around that very important capital ‘A’ :question: Maybe even distinguish that an ‘A’ record should be created by making a subdomain (in GoDaddys case that ‘A’ record is hard to find and edit if you use GoDaddy Cpanel UI, read below), that subdomain redirection is not the same thing as pointing in an ‘A’ record and that there is a difference between ‘pointing’ and ‘redirecting’.

Now for the blow by blow details on how I fixed this (for those that follow here and have the same problem):

In the current GoDaddy Cpanel UI for my ‘Linux hosted site’ there is no access to ‘A’ records. I only seemed to be able to make ‘MX’ records under Cpanel Zone Editor.

In Cpanel, I removed the ‘redirection’ IP address since this is NOT what is needed… I needed an ‘A’ record that ‘points’ to my assigned DigitalOcean IP address.

The hard part here was to find out where to access that ‘A’ record which was made when you created a subdomain in Cpanel.

I ended up calling GoDaddy support for that, I hate having to ask for help :sob:

Here is how you can access that ‘A’ record on GoDaddy Linux hosted sites and change the ‘Points to’ value (YOU CAN NOT ACCESS THEM FROM CPANEL) :sob: :


THEN:

THEN:

.
.
.
THEN, wait the requisite number of hours (up to 24 in GoDaddys case) for the change to take effect.

That is what I am doing now, I will report back whether it worked :wink:

This worked and was a solution for me (although I am not quite sure why I only needed the DISCOURCE_HOSTNAME PREFIX as the ‘Host’ in Step 6 of my images).

4 Likes

Good suggestion :+1:

4 Likes