No container created during install

I followed the directions here: discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub

I am installing on a fresh install of Ubuntu Server 18.04.4 LTS, but after finishing the setup script, it dies claiming it failed to build the app and then that there is no container. doctor and launcher both fail with the same error.

docker: Failed to create the container ID file: open cids/app_bootstrap.cid: no such file or directory.

When I run docker --version it returns Docker version 18.09.9, build 1752eb3

I have delete /vars/discourse and recloned and ran it again twice with the same outcome.

Any ideas how to rectify this? Any more information I need to provide? I am not veering in any way from the documented instructions so I am not trying to do anything custom etc.

Thanks!

Where is this ubuntu server hosted? It sounds like it’s not running in true virtualization.

1 Like

Good call! It is running in a VM on my Synology NAS and when I check /proc/cpuinfo, I don’t see it vmx enabled, I don’t see a way to enable it, but I’ll take that up with them!

1 Like