Not able to send the email on digital ocean

I have created the droplet on digital ocean. Using the inmotion SMTP details .
I am not able to receive the email. The sign up page goes to 404 not found error.

Did the troubleshooting and telenet on the digital ocean server was done. Following error is show.
Is DO blocking my email or Inmotion hosting ? Any suggestions.

image

I don’t know how that could happen.

How did you install discourse?

I used the digital ocean one click link. I am getting the 404 not found page. I did the Telnet to my SMTP server for trouble shooting.

I am getting error 200 - you are not allowed to send the mass emails. - the message I posted above.

My hunch is that - while setup, discourse is establishing smtp connection, refusal of connection is timed out and takes to another page (404 not found).

I need advise on how to rectify the SMTP server error. I am using inmotion hosting.

Did you had a previous account on Digital Ocean? Which port is SMTP using?

I ask this because Digital Ocean blocks port 25 on accounts that doesn’t have at least 6 months.

Mariano, I am using default port 586. This is the new account with DO.

I have main domain on Inmotion hosting - www.example.com and have email account admin@example.com. Have the inmotion settings for this email accounts.

I have created sub domain as forum.example.com this is redirected to digital ocean. Don’t have any SMTP settings on DO.

Any suggestions from experts ?

I don’t see that message posted above. I suspect that means that inmotion hosting doesn’t want you to use their SMTP server to send what it considers “mass emails.” You can ask them about the error. We cannot know.

You should probably use one of the recommended mail providers like Mailgun.

See discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub for how you should install Discourse. When you’re ready to reconfigure and use a different mail server, try doing this:

cd /var/discourse
./discourse-setup
5 Likes
  1. I have contacted Inmotion hosting and yet to receive the response.
  2. In first instance, I used the custom method of installing. It didn’t worked, than I changed few parameters and rebuild. Finally tried one click method.

In trouble shooting, did the telnet and posted the error. This looks like SMTP is not allowing the mails.

Will do the mailgun or other provider. Thanks for all the suggestions so far.

1 Like

Finally I was able to install the discourse with lots of learning.

  1. I was using the inmotion SMTP server and which doesnt allow the external email messaging. As suggested by forum members, utilised mailgun
  2. It is important to follow all the mailgun setup steps. It will ask you to add DNS records on the main domain and will authenticate. This may take 15/20 mins.
  3. Even after that, the discourse didnt worked. I killed the droplet multiple time.
  4. I noticed the my subdomain records were having old IP address. Cleaned up all the subdomain records (DNS Zone).
  5. Finally the email was received and after validating the link - 14 step wizard appeared.

The forum is worth all the effort and very happy for that :slight_smile:

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.