Old docker image


(laktak) #1

I finally upgraded our discourse server (including OS & Docker).

I had to destroy and bootstrap again because of problems. It’s running v1.6.0.beta1 +178 now but I still see only this image:

root@disc:~# docker images
REPOSITORY             TAG                 IMAGE ID            CREATED             SIZE
local_discourse/app    latest              370fea60556d        36 minutes ago      1.635 GB
samsaffron/discourse   1.0.8               76762729d2a1        13 months ago       1.143 GB

Is this correct?


Sidekiq not launching Jobs
(Sam Saffron) #2

Try running

./launcher cleanup


(laktak) #3

bootstrap, etc. all worked but this fails with:

root@disc:/var/discourse# ./launcher cleanup             
                                                             
The following command will                                   
- Delete all docker images for old containers                
- Delete all stopped and orphan containers                   
                                                             
Are you sure (Y/n):                                          
                                                             
Starting Cleanup                                             
awk: line 2: function strftime never defined                 
awk: line 2: function systime never defined                  
write /dev/stdout: broken pipe                               
8078820                                                      
8078816                                                      
awk: line 1: syntax error at or near *                       
awk: line 1: syntax error at or near *                       
awk: line 1: syntax error at or near *                       
awk: line 1: extra ')'                                       
awk: line 1: syntax error at or near {                       
./launcher cleanup cleared up 4 of disk space.               

(laktak) #5

Btw, samsaffron/discourse 1.0.8 is the only image on the system. Should bootstrap have downloaded a newer one? It updated everything else.


(Sam Saffron) #6

try…

cd /var/discourse
git pull
./launcher rebuild app

(Jeff Atwood) #7

Also be sure to type the word “cd” in blue, that part is very important. If you use a regular non-blue cd command, it won’t work.


(laktak) #8

Can’t rebuild at the moment but I’ll try as soon as the colors align!


(laktak) #9

It worked, thanks!

Not sure how I can say that so I meet the 20 character minimum. Maybe “Dude, it pulled, it rebuilt and then it fukcing launched. Totally discourse!”


(Sam Saffron) #10

Suggestion, just select my answer as an “accepted answer” even less work than typing 20 chars :slight_smile:


(Jeff Atwood) #11