Onebox is inconsistent with admin white-listed links


(Jason Wojo) #1

I’ve noticed that Onebox seems to behave a bit randomly with links to sites I have added to the whitelist. In fact, my own site had to be added to the list before it worked internally with Oneboxing.

Here’s example:

  1. I grab a link from a Medium post and drop it in its own line. Nothing happens.
  2. User error! I realize the user has a custom URL blog.somesite.com.
  3. I add both blog.somesite.com and somesite.com to Onebox.
  4. I go back to post and drop in the original blog link. Nothing happens, including no “spinning” that indicates it is thinking or searching for link.
  5. I also drop in a link from the somesite.com website. Nothing happens.
  6. I put in a link from Twitter and it works as exepected.
  7. I post.
  8. I try “Rebuild Html” to see if that does anything with the links. It doesn’t.

Any suggestions for fixes. Is there a way to get Onebox to re-index links or see errors?

I know Onebox is a separate project and I certainly understand the benefit to not using a service with pricing tiers like Embedly. However, I’d prefer to have all urls white-listed and admin let me block links instead of the other way around.

My instance is mostly private and all trusted users, so there is no fear of malicious links. This isn’t the case for all sites of course.


(Rafael dos Santos Silva) #2

This is listed to version 1.7 on the #releases.


(Jason Wojo) #3

Oh, yes. I see that now. Good to know!


(Felix Freiberger) #4

Yes – wait some time, I think 24 hours. Oneboxing results are cached for this time.
If you just want to test the new settings, appending a query string forces a re-check.


(Jason Wojo) #5

Thanks for the tip. I tried the query string method and it didn’t appear to check. Although, the only visual cue I have is when there is the little spinning placeholder-thingy (a technical term) that shows me Onebox is thinking. It wasn’t thinking.


(Felix Freiberger) #6

I always call these “spinners”, but “little spinning placeholder-thingy” is probably the official terminology :wink:

Hm, strange. I just tested this again and it works. You simply appended something like ?1337 to the URL, right?


(Jason Wojo) #7

Well, chalk that up to User Error. I was using an old base url for one link. The other I checked in Iframely and it didn’t have a card show up. So working now with the source trick. Thanks!


(Jeff Atwood) #8

“Onebox all the things” is released in the current 1.7 version.


(Jeff Atwood) #9