Oracle Cloud hosting with ARM-architecture

I‘ve read about your experimental ARM support.

However, I am not sure if I have paid attention to everything that has to consider for ARM.

In the end, the installation was stopped. The error message seems unhelpful to me.

What do you think?
discourse/ at main · discourse/discourse · GitHub

Pups::ExecError: cd /var/www/discourse && git fetch --depth 1 origin tests-passed failed with return #<Process::Status: pid 141 exit 128>
Location of failure: /usr/local/lib/ruby/gems/2.7.0/gems/pups-1.1.1/lib/pups/exec_command.rb:117:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"code", "cmd"=>["git reset --hard", "git clean -f", "git remote set-branches --add origin main", "git remote set-branches origin $version", "git fetch --depth 1 origin $version", "git checkout $version", "mkdir -p tmp", "chown discourse:www-data tmp", "mkdir -p tmp/pids", "mkdir -p tmp/sockets", "touch tmp/.gitkeep", "mkdir -p                    /shared/log/rails", "bash -c \"touch -a           /shared/log/rails/{production,production_errors,unicorn.stdout,unicorn.stderr,sidekiq}.log\"", "bash -c \"ln    -s           /shared/log/rails/{production,production_errors,unicorn.stdout,unicorn.stderr,sidekiq}.log $home/log\"", "bash -c \"mkdir -p           /shared/{uploads,backups}\"", "bash -c \"ln    -s           /shared/{uploads,backups} $home/public\"", "bash -c \"mkdir -p           /shared/tmp/{backups,restores}\"", "bash -c \"ln    -s           /shared/tmp/{backups,restores} $home/tmp\"", "chown -R discourse:www-data /shared/log/rails /shared/uploads /shared/backups /shared/tmp", "find public/plugins/ -maxdepth 1 -xtype l -delete"]}bootstrap failed with exit code 128
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.

Maybe a network error? Have you tried again? Is the error consistent across multiple tries?

1 Like

Yes, it happens multiple times.

Thank you for this hint. I guess, the default firewall restrictions are the reason for this. I found the key hint inside the log …

fatal: unable to access ‘GitHub - discourse/discourse: A platform for community discussion. Free, open, simple.’: Could not resolve host:

Yes, if the installer can’t access the internet it’s going to be a bad time.


Very strange, especially because Discourse seems to be successfully downloaded.

This must be something special.

You successfully downloaded the Discourse “installer”, but downloading Discourse is what would happen on the failing step.

Are you using the Oracle weird distro? Unless I’m mistaken it has some issues with DNS inside the container that requires extra step configuring the Docker service.

Maybe try running a more common arm compatible distro like debian?

  • Ampere Altra 80C, 6 GB Ram
  • Canonical Ubuntu 22.04, Image-Build:2022.08.10-0

Actually, it should have worked. I even disabled the Oracle Cloud and Ubuntu firewall completely as a test. However, without success.

The project has died in the meantime.

Will maybe try it another time with the Raspberry Pi.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.