"Page" query string from search engine breaks content


(Mufid) #1

This is broken. Only show blank content.

https://meta.discourse.org/t/tuning-ruby-and-rails-for-discourse/4126?page=5

However, if i omit the page query string, the content is loaded:

https://meta.discourse.org/t/tuning-ruby-and-rails-for-discourse/4126

(Mittineague) #2

I tried with JavaScript enabled - not a complete wash out (but Bad) - using the timeline “breaks out” if one thinks to try using it.

I tried with JavaScript disabled - not good - got
Tags: #<Tag:0x007fbb686c7160>


(Sam Saffron) #3

Hmm, I guess the “bug” here is that we are not returning a 404, there is no page 5 on that topic.


(Mufid) #4

I see. Seems like Google indexed wrong url?

I get that url from this keyword:


(Sam Saffron) #5

I will have a look

This may be an office space class off by one error


(Ryan Mulligan) #6

Hi.

@sam, was this off-by-one issue resolved? I think I may be seeing the same issue because the second link in this Google search

https://www.google.com/search?q=pololu+metabeam

is

https://forum.pololu.com/t/new-products-zumo-shield-and-zumo-robot-kit-for-arduino/5161?page=2

And, clicking on that link gives a 404 because there is no page 2.

Ryan


(Sam Saffron) #7

I need to find where the link is coming from cause I am not seeing it here https://forum.pololu.com/t/new-products-zumo-shield-and-zumo-robot-kit-for-arduino/5161?_escaped_fragment_=true