Png favicon not appearing in Chrome (Mixed content error)

Hi,
The 32x32 favicon that I uploaded into a https locally hosted discourse is going into the HTML with

<link rel="icon" type="image/png" href="http://discourse.jalview.org/uploads/default/optimized/1X/c29815ed01e3ce7d1cc583ccc9feaada4bae5d4b_2_32x32.png">

and you can see the problem in Chrome:


and

Is there a way to force this to be an https URL?

Thank you!
Ben

Yes, and it is enabled by default when you setup a new Discourse install using a proper domain. If it failed, or this an old install you can ssh and:

cd /var/discourse
./launcher enter app
rails c
SiteSetting.force_https = true
1 Like

@Falco Thanks that has fixed it.
The local discourse is behind a reverse proxy and so the actual install probably wan’t running as https when first installed.

1 Like