Postgres Minimum Version


(Aman Gupta) #1

README states 9.3+ is required. But using 9.4.18 I am seeing errors in Jobs::UpdateUsername

PG::UndefinedFunction: ERROR: function jsonb_build_object(unknown, text, unknown, text, unknown, text, unknown, text) does not exist
LINE 4: jsonb_build_object(

It appears that jsonb_build_object was added in 9.5


(Jay Pfaffman) #2

Standard install:

# psql --version
psql (PostgreSQL) 10.3 (Ubuntu 10.3-1.pgdg16.04+1

That’s what I’d recommend. You can search here, but I think 10 is required.


(Jeff Atwood) #3

@rishabhn can you update readme as you have time.


(Rishabh Nambiar) #5

I’ve updated README.md and a few other docs, Thanks @tmm1 :+1:

I’ve just bumped it from 9.3 to 9.5 for now because Ubuntu 16.04 still ships with 9.5 :thinking:


(Rafael dos Santos Silva) #6

We should really point to 10, since it’s what we use on every install.

PostgreSQL officially supports Ubuntu 16.04: Apt - PostgreSQL wiki


(Rishabh Nambiar) #7

Sure, I’ll change it back to 10!

I chose 9.5 because on a fresh 16.04 droplet:

apt install postgres -> installs 9.5
apt install postgres-10 -> doesn’t have an installation candidate

so our instructions here will not work on 16.04:
discourse/DEVELOPER-ADVANCED.md at master · discourse/discourse · GitHub

Can I update that guide to say Postgres 10 & Ubuntu 18.04?


(Rafael dos Santos Silva) #8

Yes, the guide should point to the official PostgreSQL docs for installation, so it will work in any distro/version.


(Rishabh Nambiar) #9

Awesome, it is done: Change postgres version 9.5 to 10 in docs/ and README.md · discourse/discourse@0dd9898 · GitHub :balloon:


(Jeff Atwood) #10