Recent change? Pasting content from Word/Outlook, loses formatting and hyperlinks

My org’s president writes a lengthy message every 2 weeks to share with the community. She writes it inside of Microsoft Word because she’ll spend several days working on it.

Suddenly, we’re finding that when we copy/paste from Word (or Outlook) into the “create topic” box in Discourse, formatting gets stripped away which includes things like, bold, italics and hyperlinks.

I’ve tested from different computers too. My president is not happy. :frowning:

What version of Discourse are you using? Basic formatting should get converted to markdown unless you contrive not to have it do so.

What os and browsers have you tried?

Which browser is on these machines? Edge changed how it handles pasting a little while back.

1 Like

Thanks. I’m a hosted customer and I can’t tell which version I’m on, but my Admin screen says it was last updated on September 1. I have tested the pasting from Chrome and Firefox on two different Windows 10 PCs.

But I just discovered that if I copy/paste just a few paragraphs at a time, the formatting and hyperlinks paste over into a new topic box correctly. Weird.

On Saturday, my temporary work around was to copy/paste the entire 5-page document text into another HTML editor (quackit.com), and then from there I re-selected the text and successfully copy/pasted it to Discourse.

So I have to conclude there’s something amiss in the paste-content function in Discourse for larger bodies of text?

For reference Edge is mischievous here:

1 Like