Set up Discord notifications using the discourse-chat-integration plugin

I closed the page and tried agin and it worked. Thank you

This is wonderful, however I’m wondering if it’s possible to:

Set thumbnail on the embeds?
How to do proper line breaks in the embeds?

Would really appreciate if someone could provide some more details on this, and if possible also footer settings.

This plugin works great - thank you!

The question is that the ‘tag only’ rule seems a bit inconsistent in working. It seems to work when first created as a Rule under a Discord webhook channel, where we look for a tag (say #chat) but then it seems to stop sending out updates after 5 minutes or so.

Could it be a rate limit thing that Discord have added? I couldn’t see anything in the logs on the Discourse side.

This could very well be rate limiting yes.

Discord allows you to make 5 of “any” requests to their API per 5 seconds, if you exceed this you’ll be rate-limited as described here:

Discord Developer Portal - Rate Limits

2 Likes

Would it be possible for this plugin to support posting thread links to more than one discord server? I’m assuming this would require custom development.

1 Like

Can this only post a message into a specified Discord channel when a new topic is made in a specified category on the forum? Or will it post every post in a category? I just want new topics not replies.

When enabling chat integration and Discord, all I see is this with no other options to create channel. Is this plugin still up to date for version 2.6.0 beta ?

The channel/rule configuration is in a different part of the admin panel:

1 Like

Thank you! I just searched for discord in the admin panel and also tried going directly to the plugin’s settings. I didn’t realize there was a sub tab.

When I go to Chat Integrations -> Discord, there’s no channel or settings button. Just ‘message content’ and ‘excerpt length.’ Nowhere to paste my Discord webhook. Help?

I have the same issue as @billnew


Thats all I see!

You need to visit the “plugins” tab at the top of the screen. Not the plugin tab on the left of the site settings

1 Like

I did.

Can you try refreshing the page? A refresh will be required after enabling the plugin.

3 Likes

I see it now, thanks!

he guys. getting a error setting up this plugin with discord. channel created. webhook setup with the plugin.

now i get the next error.

and when i send a test. i get this error.

and the logs give me this.

any help would be appreciated.

Can you share the contents of the “info” tab for this? If you can copy/paste, that would be great - it’s hard to read logs in a screenshot.

1 Like

Message (2 copies reported)

Test provider failed {:error_key=>nil, :message=>{:content=>"", :embeds=>[{:title=>"FAYN Rule Book [Alliance/Announcements] ", :color=>12525102, :description=>"[image] \nFAYN is a group of Corporations working together as a collective to grow both the individual and the group within this set of guidelines and rules. \nAdministration Tools\nAs part of FAYN you are required to have  ALL  of your characters, however insignificant linked to your main character on SeAT  This is part of the recruitment requirements and supports the ongoing management of our corp...", :url=>"https://forum.darksideoftheeclipse.co.uk/t/fayn-rule-book/45/1", :author=>{:name=>"@PJHustle", :url=>"https://forum.darksideoftheeclipse.co.uk/u/PJHustle", :icon_url=>"https://forum.darksideoftheeclipse.co.uk/user_avatar/forum.darksideoftheeclipse.co.uk/pjhustle/45/4_2.png"}}]}, :response_body=>"<html>\r\n<head><title>403 Forbidden</title></head>\r\n<body>\r\n<center><h1>403 Forbidden</h1></center>\r\n<hr><center>cloudflare</center>\r\n</body>\r\n</html>\r\n"}

Backtrace

/var/www/discourse/plugins/discourse-chat-integration/app/controllers/chat_controller.rb:43:in `rescue in test'
/var/www/discourse/plugins/discourse-chat-integration/app/controllers/chat_controller.rb:22:in `test'
actionpack-6.0.3.3/lib/action_controller/metal/basic_implicit_render.rb:6:in `send_action'
actionpack-6.0.3.3/lib/abstract_controller/base.rb:195:in `process_action'
actionpack-6.0.3.3/lib/action_controller/metal/rendering.rb:30:in `process_action'
actionpack-6.0.3.3/lib/abstract_controller/callbacks.rb:42:in `block in process_action'
activesupport-6.0.3.3/lib/active_support/callbacks.rb:112:in `block in run_callbacks'
/var/www/discourse/app/controllers/application_controller.rb:354:in `block in with_resolved_locale'
i18n-1.8.5/lib/i18n.rb:313:in `with_locale'
/var/www/discourse/app/controllers/application_controller.rb:354:in `with_resolved_locale'

Env

HTTP HOSTS: forum.darksideoftheeclipse.co.uk

First resort should be to contact Discord support with this information and ask why this is happening.

1 Like

yeah maybe. but i will pass. i am not a dev. and have no clue what to do or what to ask. i dont understand much about this. just posting this as it used to work. now it doesnt.

maybe cause discord is changing stuff ? no idea.
i have a feeling i wont be the only one getting this issue soon.

It is helpful to share, we’re just pointing out that based on the data it looks like the problem is on Discord’s side. We can’t control that.

1 Like