Setup wizard emoji wrong in subfolder install

subfolder

(Neil Lalonde) #22

I feel like we’ve fixed this before. Such deja vu… :open_mouth:

I don’t think we need anything else from you @UnivacTwo


(Neil Lalonde) #23

@UnivacTwo I made two fixes for broken images: the emoji in the wizard, and the image on the password reset page.

Note that there’s still a bug on the password reset page which isn’t specific to subfolders though. The image’s dimensions are 0 so it isn’t shown. EDIT: fixed.


(Flaviu) #24

Thank you @neil

How can I get this latest version? Just a reinstall should do the job?

I will also let you know if I found additional images/links/other type of assets with the same problem


(cpradio) #25

Once the commit is in tests-passed, you can remote into the system using SSH and navigate to /var/discourse, then run ./launcher rebuild app


(Flaviu) #26

OK, so how do I know when the commit is in tests-passed state? I don’t even know which commit is this one.


(cpradio) #27

Looks like it is. As the two branches are identical
Comparing master...tests-passed · discourse/discourse · GitHub


(Flaviu) #28

@neil I just found out that also the logo has the same problem. The reason I haven’t brought it up was that I override it adding in the admin section bellow the folder name in front of the images, but I just realized that if I d this the images are not rendered correctly in the emails.

Can you please look at these images too?


(cpradio) #29

Just to be clear, are you referring to the Logo displayed in the Wizard Dialog, or on the Discourse pages too? The settings you took a screenshot of would impact emails and the Discourse pages (and ideally the Wizard too – but that might not be taking the subfolder into account)


(Flaviu) #30

I am referring to the discourse logo not in the wizard.

here is how the HTML source code look. You can see that the a href path is corect, having the folder name correct, but the logo is not <img src="/folder-name/images/d-logo-sketch.png" …


(Kane York) #31

Those are just the default settings; either replace the defaults or add your subfolder path in.

It’s technically weird to make the default setting values change based on whether or not it’s a subfolder install, and most sites won’t be using those defaults anyways.


(Flaviu) #32

I am not talking about the defaults that appears in admin

but in the website it is normal to have the subfolder path in the image src the reason is that this is the corect path of all the images of the website when you install it in a subfolder.

If you override this, and manually add the folder name before the image in the admin, ( which is a hack for subfolder instalation ) then the path of the logo in emails is going to be incorect because it will have the subfolder name added automatically, in addition to the one that you add in the admin and in this case the logo path is going to be img src=“www.example.com/subfolder/subfolder/img/logo.png” which obvious is wrong and the logo is not rendered in the email clients.

In this case I I think the only solution is to repair the bug

(the same path problem is for favicon.ico)


(Neil Lalonde) #33

I agree with @UnivacTwo that this is a bug. We support the default logos in emails, and we should in the header too.


(Flaviu) #34

Thank you @neil you are great :slight_smile: Have you been able to fix the favicon too?