Spaces adjacent to emoji text?


(R Zarni) #1

I have up to last version , There was a lot of user bugs in the latest post.

eg:

TEST:relaxed::relaxed:

TEST:relaxed::relaxed:


(Joffrey Jaffeux) #2

Are you sure it used to work ?

I can reproduce on an instance with Discourse 1.8.3.


(Joffrey Jaffeux) #5

@zogstrip is it the issue you told me weeks ago, about the difference between french/english where one expects space before : and the other doesn’t?


(R Zarni) #6

now version is 1.9.0.beta4

The error occurred in the new version emoji UI, and The new UI is very friendly to the phone.

99% User feedback is bad:joy:


(Joffrey Jaffeux) #7

I’m fully ready to fix things, but I can’t fix anything with this kind of feedback, and this is not the feedback we have from other sources. So please tell me:

  • what’s not working
  • what’s the expected behaviour
  • how to reproduce it

Concerning your first question, I might be wrong but I’m almost certain it’s not related to the emoji picker (and it doesn’t mean we shouldn’t fix it).

Also are you exactly on the 1.9.0.beta4 tag commit, or on master ? If not on master you might want to upgrade as A LOT of fixes have been issued concerning the emoji picker since this tag.


(R Zarni) #8

hello, I use test-passed.

what’s not working
what’s the expected behaviour
how to reproduce it


If there is no space at the end:disappointed_relieved:

canot show emoji.


(Jeff Atwood) #9

That is by design. There is no expectation that

randomtext:smile:

should work… nor

:smile:randomtext


Emoji-picker automatically add spaces
(Stephen Chung) #10

I wonder why. This is probably done to prevent conflicts with program code for languages which use a lot of.colons.

Many forums, however, has nothing to do with programming. So it is very rare for colon usage like this to be valid other than an emoji.

At least it should be a site setting…