Surprising behavior: This image is too large to display; click here to view


(Dave McClure) #1

I find this behavior surprising:

  1. I post a link to an image on it’s own line, like the one below from the article.
  2. It shows up in the preview fine
  3. I create the post
  4. It shows up fine in my post for a while.
  5. Later, it gets replaced with a thumbnail saying: “This image is too large to display; click here to view”

Onebox link:

Preview screenshot:

After post screenshot:

After image is replaced screenshot:

TODO


(Dave McClure) #2

Looks like the problem isn’t happening here. Maybe it’s a site setting I need to adjust to work around this issue?


(Daniela) #3

What’s the value of max image size kb?


(Dave McClure) #4

Currently it’s 4MB (4096 KB). Looks like that image is 35 MB.

What have others set that to nowadays?


(Jeff Atwood) #5

This is in @vinothkannans list of things to improve. The behavior is correct but the UI could use some work.


(Dave McClure) #6

If there were anyway to make it clear this would happen in the preview, that would make it a lot less surprising.

Also, it wasn’t clear to me what “too large” meant, as there are site settings both for file size and for dimensions. I wasn’t sure which setting would need adjusting with the current language.


(Vinoth Kannan) #7

PR created. The new UI won’t create confusions.


(Régis Hanol) #8

The issue is that we’re doing some magic :sparkles: server-side to automatically downsize big images which we can’t really do client-side.

I agree. One setting is only used to create thumbnails, the other is to prevent mobile users from wasting their bandwidth downloading a gigabyte GIF.


(Dave McClure) #9

Cool, thanks. What happens in the new UI?


(Vinoth Kannan) #10

As you can see it will have some explanation.