Synchronizer-base for any backup provider

Thanks for your quick response. I’ll test it out today and let you know.

:slight_smile:

I updated to the branch and ran a backup manually. Should it have triggered the backup to Box with a manual backup, or only when backups happen automatically?

It should be triggered when you click backup. What happens is that if the plugin setting is set to enabled in the discourse core model there is an event triggered that runs the job in the plugin.
The job synchronizes the backup files.
Are you sure you have your account for box set up properly with the right api key and everything?
If it still doesn’t work, can you post the logs?

I can manually queue the job and it successfully uploads to box so my box creds have to be correct.

Which logs were you referring to? Sidekiq? The logs that are generated when I click on backup?

Yes! And/or just warns you if you try to activate a backup plugin without the base plugin enabled. And since I was debugging for someone else’s dropbox account (in another time zone), the debugging cycle was painfully long.

I just rebuilt and Dropbox is working now (I was about to report a bug but it was fixed the day after I last rebuilt. I rebuilt just now and it’s working! Thanks.)

1 Like

Hi all,
I’m trying to use your plug-in for a backup to nextcloud. I don’t know much about docker and global architecture of discourse, so I followed this topic to install your plug-in Install Plugins in Discourse.
It worked well installing the discourse-sync-base and boostraping the docker image.
Installing the Discourse Sync to Nextcloud faills using the same technic. I get a bootstrapping error on ./launcher rebuild app
Do you have any hint ?
Thanks

1 Like

Can you share the error? Please upload the entire build log - you may need to use something like Pastebin if it is particularly large.

1 Like

Digital Ocean Spaces, is a S3 API-compatible storage service that sounds very good for Discourse, since so many Discourse instances run o Digital Ocean

4 Likes

I was already thinking that, but in order to make a test account, I have to use my credit card details and they don’t accept a test card, so I got freaked out. But in general it is a good idea!

great, but how can i set this up?

thanks

It looks to me like to be able to use it you’ll need to add a bit of code to the S3 pull-down that selects the region, right?

1 Like

I have setup for The discourse-sync-to-googledrive just as shown here https://github.com/berlindiamonds/discourse-sync-to-googledrive but somehow no activity of backup to Google drive is seen for a month or so. Also no other errors showing up in log.

Thanks,
Jay

for Google drive backup i can see “admin/plugins/discourse-sync-to-googledrive/downloader” backups but where can i download them? when clicked on download button it does nothing… but on Google developer console i see 21 request being made.

@kajatiger interesting one here. Installed, it and it is sorta working. Backup file is created in Dropbox, however each backup is only 58 bytes.

Any idea what could be going on?

image

Please help with this problem in the post below:

1 Like

Here is the link:
https://github.com/berlindiamonds/discourse-sync-to-googledrive

4 Likes

Sorry i was facing a problem with the plugin and i missed to share the link to the post

Please see the post below:

I am using the plugin to backup to dropbox:

I just discovered that my backups don’t seem to be stored on dropbox but locally on the server:

What I see on my dropbox account are just some very small (most of them are just 48 Bytes) tar.gz files:

Nothing in the logs. What might be going wrong here?

It sounds the same as this:

Yes, except that Jay doesn’t see any files on Google drive while I seem to get a few bytes transferred. Also, I’ve had this working for months. Not sure about Jay.

Can anyone confirm that the plugins are working for them?

3 Likes