Unable to set a custom theme as Default on 2.8.0.beta7

Hello there, I noticed that the " Theme is enabled by default" checkbox in the Customise > Theme options automatically uncheck itself after a refresh of the theme options page. Basically it’s impossible to change the default theme. Other users see the basic default Discourse theme.

I tried to delete the default theme, in the hope the only enabled theme (checking “Theme can be selected by users”) becomes the default for everyone, but it’s not working either, other users, as well as logged out users, keep seeing the default theme, even if it’s not installed!

The annoying thing is that the issue happen with any theme I try to install and set as default.

I also tried to force the " default theme id’ via the global settings > basic setup, but it’s still not working.

We are running 2.8.0.beta7 in our community: https://poloverse.net/

what do you think I can do to solve the problem? I know we are behind updates, do you think this bug is something has been addressed in some later release?

Thanks in advance!

Little point in reporting a bug on an old outdated version? The current supported beta is 3.3.x

The first advice you will receive is “update” and recheck :slight_smile:


Yes I know, I suspected this kind of answer… and I agree, unfortunately I can’t update it on my own, but I’ll talk with the server admin to do so. Thanks for the suggestion.

Anyway, if anybody experienced this kind of issue, it would be great to hear if there is a workaround.

1 Like

I cannot reproduce this issue in 3.3.0.beta1-dev

Make sure you are hitting the little additional tick to commit the change.


(This is similar to a granular “Save” button)


Thanks @merefield, yes I tried that, it was quite clear, unfortunately it doesn’t work, it just don’t keep that setting saved

1 Like