Uploaded avatar or gravatar not working

Hello,

I seem to have the exact same symptoms as How to fix user avatar? but I’m running the latest version of discourse (I tried to upgrade to fix this).

Upload works fine (file are being uploaded to the shared folder) but when the users save his profile, it goes back to the default avatar. It’s the same for gravatar.

Any idea how to solve this ? Thanks

Did you restart / rebuild your container?

Yes I did several times (and upgrade to a newer version)

Then we need more information. Do you have any non-official plugins installed? Are there any errors in logs that might be related?

1 Like

Here’s my setup :

  • forum run under /forum/foo
  • upload folder is remaped (and it works fine for other images : logos, post, favicon)
  • plugins : discourse-edx-lti, discourse-solved

This is the only log related to images that I have

I have an alternate setup with an equivalent config where everything works fine…

Subfolder is not a recommended config.

Yes I aware of that but it works pretty good and sometimes you don’t have a choice…

Thanks anyway

Ok I solved it.
It was due to the forum being in a subsubfolder ie /forums/foo, I followed this guide to set up the forum but it was missing a symbolic link to reflect this subpath.

So I added :

# ...
- mkdir -p public/forum/foo
- cd public/forum/foo && ln -s ../../uploads && ln -s ../../backups
2 Likes

There is always a choice :wink:

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.