URL do not support Vietnamese Không hỗ trợ tiếng Việt

If you click to this link: URL do not support Vietnamese Không hỗ trợ tiếng Việt
You can see that: for Vietnamese language “Không hỗ trợ tiếng Việt”, it should be “khong-ho-tro-tieng-viet”, but it changed to “khong-h-tr-ti-ng-vi-t”. It makes this link look ugly.
Please help me to fix it.

2 Likes

It doesn’t work on meta, because the default_locale is set to English. But it will work when you change the default_locale site setting to Vietnamese.

image

image

6 Likes

Thank you very much!
But when I change to Vietnamese Language, “Vote” changes to “Đã Bình Chọn”, so the button can not cover the word. How can I fix it? (Can we make the size of button bigger to cover all words?)
16%20PM

Theo mình nghĩ, bạn chỉ cần chỉnh lại CSS là ok. Bạn có thể cho xem website để mọi người có thể giúp!

2 Likes

Hi. Can we just change location to VietNam ( to make url friendly) but keep the rest? I want to use English ( the original)

Unfortunately that’s not possible at the moment. You could create a feature request in the #feature category if you wish.

As an alternative you could change the value of the slug generation method site setting.

“encoded” would look like this:
image

Or you could disable the slug by setting it to “none”:
image

4 Likes

Dear anh @cuongnguyen uong, không biết đến thời điểm hiện tại anh đã xử lý được vấn đề này chưa ạ?

Thank you so much :heart: