Users unable to login with Discourse Connect

It is a Docker-based set up. SSO login used to work seamlessly until I restarted the server. Now, every time user tries to log in, the user is shown this TimeOut Error.

What I have tried so far -

  • Changed the secret key.
  • Disabled “Must Approve User” setting.

Nothing worked so far. Any inputs & pointers would be appreciated.

Thank You!

Have you tried looking for more error messages at :mag:

1 Like

It looks like Discourse cannot connect to your SSO server. Hard to guess why. Do stuff like reboot the machine, check that Docker is up to date, try to telnet from inside the container to your SSO server, see if your sso server is online, has sso server got some new firewall keeping you from connecting. Stuff like that.

I can see why the SSO login is failing.

Verbose SSO log: Nonce is incorrect, was generated in a different browser session, or has expired add_groups: admin: moderator: avatar_force_update: avatar_url: bio: card_background_url: email

So, we have embedded the discourse inside our web application using iframe. I don’t see why this could be a problem since we are using this set up for the last 18 months.

What do you think could be the issue, because nothing has changed?

Hi. I have the same issue when using discourse SSO in iframe. Did anyone solve this issue?